Search Unity

  1. Unity 2019.1 is now released.
    Dismiss Notice

Running script to turn off segment scale compensation in Maya 2017 messes up my model

Discussion in 'Animation' started by jessowang, Aug 13, 2018.

  1. jessowang

    jessowang

    Joined:
    Mar 7, 2017
    Posts:
    1
    Hello! I'm trying to export my rigged model of a flower from Maya 2017 to Unity 2018.1.1f1. It looks like this:

    When I exported it as fbx to unity it looked like this:

    I figured this was because of the segment scale compensation from Maya so I ran this script to turn it off for all the joints in Maya:
    {
    string $selected[] = `ls -type joint`;
    select -r $selected;
    }

    string $sel[] = `ls -sl`;
    string $singleJnt;
    for ($singleJnt in $sel)
    {
    setAttr ($singleJnt + ".segmentScaleCompensate") 0;
    }

    But now in Maya it looks like the messed up version as well.
    Is it possible to turn off segment scale compensate in Maya and preserve my model? Or do I just have to redo it....
     
  2. Martawen

    Martawen

    Joined:
    Oct 22, 2018
    Posts:
    1
    Since noone replied...

    Sadly I can't help (would be rather late as well), but I have pretty much the same question... Maybe asking this question again will make someone answer who might know? Or maybe you fond a solution by yourself?

    I would be so glad if someone could help, because it's awful to have to do a lot of rigging again...