Search Unity

  1. Unity Asset Manager is now available in public beta. Try it out now and join the conversation here in the forums.
    Dismiss Notice

Question Running ros2 topic echo "topic" throws ModuleNotFoundError: No module named 'unity_robotics_demo_msg

Discussion in 'Robotics' started by Horakles, Nov 25, 2022.

  1. Horakles


    Nov 21, 2022
    Hi all, i have a problem.

    I have connected ROS2 FOXY and UNITY, and i am trying to run RosPublisherExample, but when i open /pos_rot topic, i get an error (see the screenshot please).

    I followed these tutorials and Unity documentations:
    ROS2 installation -

    Unity Setup (the two tutorial below, but in a video) -

    ROS-Unity Demo Setup -
    ROS-Unity Integration: Publisher -

    My OS: Windows 10, but i am running ROS2 and have my Colcon Workspace in WSL2 and with Windows Terminal
    Unity Version: 2020.3.30f1
    Ubuntu version in WSL2: 20.04.5 LTS
    ROS2: FOXY
    ROS2 Domain ID: 0
    Also, i am NOT using Docker

    I tried creating Ubuntu-20.04 virtual machine in VirtualBox, but i get the same error.

    Does somebody know what causes this and/or how to fix it?
    Thank you.