Search Unity

ProBuilder Rotation handle gizmo not picking properly in face/edge mode

Discussion in 'World Building' started by hunterofakara, Oct 21, 2019.

  1. hunterofakara

    hunterofakara

    Joined:
    Oct 4, 2018
    Posts:
    19
    When I try to rotate a selected face or edge, the rotation gizmo mostly doesn't highlight when I mouse over the axis arcs in the scene view.
    Depending on the camera angle, it seems to work in limited places (Sometimes a point on the arc, other times near the empty space in the middle of the rotation gizmo).
    This affects the 3 axis lines and the free rotate outer circle.
    Occasionally one axis will highlight correctly, but never all 3 from one camera angle.
    In object mode, the rotation gizmo works perfectly as expected, but as soon as a face or edge is selected in one of the element modes, the rotation gizmo no longer reacts to the cursor position fully.
    (The transform/scale gizmos all highlight correctly in every mode)

    Had the problem in both 2019.3.0b4 and 2019.3.0b7. Package manager wouldn't properly install ProBuilder in my old 2018 install, so couldn't check if it's a new issue or not.
     
  2. wyattt_

    wyattt_

    Unity Technologies

    Joined:
    May 9, 2018
    Posts:
    292
    This is a bug and I think there has been a fix for this that should be coming soon. tagging @gabrielw_unity just in case i am spewing lies
     
  3. Rodolfo-Rubens

    Rodolfo-Rubens

    Joined:
    Nov 17, 2012
    Posts:
    1,109
    Hi, I'm using Unity 2019.3.0f1 with ProBuilder 4.2.1 and the rotation gizmo still won't work no matter what.
     
  4. Doomlaser

    Doomlaser

    Joined:
    Dec 9, 2013
    Posts:
    8
    Having the same issue in 2019.3.0f3
     
  5. kaarrrllll

    kaarrrllll

    Unity Technologies

    Joined:
    Aug 24, 2017
    Posts:
    194
    I landed this fix in the 2019.3 branch before the holiday break, it will be included in the next 2019.3 RC.
     
unityunity