Search Unity

Root node problem with Humanoid animation type

Discussion in 'Animation' started by Velo222, Nov 30, 2013.

  1. Velo222

    Velo222

    Joined:
    Apr 29, 2012
    Posts:
    1,430
    Is there a way to assign what the "root node" should be on a Humanoid mecanim character?

    My character's feet are "sliding" around during the "idle" animation, which is not what I need, and doesn't look good. If I use the "Generic" animation type within the characters rig tab (in the import settings), the animation works like it should and my character's feet stay where they should.

    I'm assuming that since in the generic animation type they let me specify what the root node should be, and it works great, that all I need to do is somehow assign a different root node to the Humanoid setting -- however there is not option to do so. Why is this the case?

    I'd really like to be able to make my character "Humanoid", especially since it IS humanoid lol. But I'm basically left with having to make it generic in order to work right. I'd love to be able to use Humanoid for re-targeting purposes.
     
  2. Velo222

    Velo222

    Joined:
    Apr 29, 2012
    Posts:
    1,430
    Thankfully I figured most of it out. "Bake Into Pose" is the main setting that made things work better for me. In the models "Animations" tab in the import settings, I had to select the individual animation I wanted to work with, then for some of the "Root Transform" settings I had to select "Bake Into Pose". Then with a combination of auto-mapping the bones in the "configure" options of the rig, and a couple other root transform things, I got it to work about 99% correct! I was somewhat hesitant to mess with the Bake Into Pose selectors because I didn't know what it did. And I still don't really lol.

    Luckily it worked for me.
     
unityunity