Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

Rigify to Humanoid not working

Discussion in 'Animation' started by Tomas_Kok, Aug 24, 2016.

  1. Tomas_Kok

    Tomas_Kok

    Joined:
    Oct 5, 2014
    Posts:
    12
    Hi,

    I am using the Rigify add-on for Blender. I have generated the rig, skinned and animated my mesh and placed some corrective shape keys. When I export my model as an fbx file to Unity, Mecanim displays all the animations flawlessly. So far so good.

    But when I change to Humanoid (which I really need for IK handling) there seems to be a problem. First of all, the bone hierarchy is a mess, even when I turn on "Only deform bones" in the Blender fbx export settings and delete all the WGT-* bones. Furthermore, the animations look deformed. It looks like the hips and upperarms do not move at all, or are not skinned at all.

    I think that I also understand why. Unity mostly uses the ORG-* bones when automapping, but as far as I understand, Rigify puts the skinning data on the DEF-* bones. A simple solution would be to just use the DEF-* bones, but the problem is that when I assign these, Humanoid complains that they are not correctly parented. Indeed, they are spread across the hierarchy, probably because their ORG-* or MCH-* counterpart bones controll their movement. I tried to reparent them in Humanoid, but apparently this is not aloud. When I apply my changes and return, all the bones are in their original position in the hierarchy.

    Am I correct about the ORG-* and DEF-* bones, or is it something else? And if I am correct, how do I update the hierarchy (without breaking my animations in Blender) or can I transfer the skinning data from the DEF-* to the ORG-* bones?