Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only. On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live. Read our full announcement for more information and let us know if you have any questions.

Question [Rider] I can't debug players built with another machine than mine

Discussion in 'Code Editors & IDEs' started by Midiphony-panda, Feb 24, 2022.

  1. Midiphony-panda

    Midiphony-panda

    Joined:
    Feb 10, 2020
    Posts:
    243
    Hello, this is kind of a follow-up of this thread : https://forum.unity.com/threads/i-cant-debug-il2cpp-build-with-rider.1157870/

    I am unable to debug players built with another machine than mine, on Rider.

    It seems Rider is able to attach itself to the running player, but the following error is displayed on my breakpoints :
    Tooltip Rider.png
    [someScript].cs it not found among the loaded symbol documents


    I don't know anyone at my studio who is able to debug/break in this use case.

    I feel like this is a very common use case in game studios, with build servers releasing builds periodically.
    Is this a known issue ? Are there some workarounds ?


    Jetbrains redirected me to this ticket :
    https://youtrack.jetbrains.com/issue/RIDER-66147

    Thanks !
     
    Last edited: Feb 28, 2022
  2. Midiphony-panda

    Midiphony-panda

    Joined:
    Feb 10, 2020
    Posts:
    243
  3. citizenmatt

    citizenmatt

    JetBrains Employee

    Joined:
    May 9, 2017
    Posts:
    9
    Hi all. Just to let you know that we’re aware of the issue, and the impact it can have. We haven’t been able to address this in Rider 2022.1, which is just about to be released, but it is scheduled for the following major release - 2022.2, due in a few months. There is a comment on the issue linked above with a couple of things you can try as a workaround, but they’re not ideal - a second copy of the source in the same location, or links/junction points in the file system. Apologies for the inconvenience, we’ll get this supported as soon as we can.
     
  4. KHagen95

    KHagen95

    Joined:
    Oct 15, 2019
    Posts:
    18
    @citizenmatt is there any update on the bug? I've hit the same issue, where I have our games built via a CI server and when I try to debug it on my machine, I can't with Rider. Tried and tested in Rider 2022.2.2 and 2022.2.3 and I can't debug in either version, which is quite detrimental to workflows of course.

    Would be happy to see a fix soon!
     
  5. sinaari

    sinaari

    Joined:
    Jan 28, 2019
    Posts:
    48
    If you're seeing this when working with Unity then try clicking the "Regenerate Project Files" button in Unity's Preferences->External Tools, and also maybe clearing all the Rider cache.
     
    Midiphony-panda likes this.
  6. Dominik-P

    Dominik-P

    Joined:
    Dec 22, 2013
    Posts:
    7
    Did you find solution how to fix this issue? It happens to me after upgrading from Unity 2021 LTS to 2022 LTS (extact version 2022.3.24f1). I have regenerated project files, upgraded Rider to the latest version 2024.1.1, cleared Rider cache and nothing helped
     
  7. ExNinja

    ExNinja

    Joined:
    Dec 4, 2013
    Posts:
    32
    When moving a Unity library (XR Interaction Toolkit) from the (Project)/Library/PackagesCache/ to the (Project)/Packages/ folder on Windows 10 Enterprise / Unity 2022.3.31 / Rider 2022.2.3, the following steps enabled me to debug the XR Interaction Toolkit files made by Unity.
    1. Quit Rider.
    2. Open Edit > Preferences... from the main menu in Unity.
    3. Choose External Tools.
    4. Under Generate .csproj files for:, check everything.
    5. Click Regenerate project files.
    6. Reopen the .cs file in Rider.
    This is basically what other people had suggested, but I wanted to lay out each step that worked for me.