Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

RI.Hid Failed to Create Device File

Discussion in 'Editor & General Support' started by Jax_Cavalera, Sep 30, 2013.

  1. Deleted User

    Deleted User

    Guest

    The patch to update 5.0.1p2 has been released, I don't think it has been fixed yet, as it's not in the changelog.
     
  2. guavaman

    guavaman

    Joined:
    Nov 20, 2009
    Posts:
    5,578
    It was in 5.0.1p1 as mentioned by @chlagou on April 15th.

    (673862) - Windows Standalone: Connecting USB devices should no longer throw spurious <RID.Hid> warnings.
     
  3. krougeau

    krougeau

    Joined:
    Jul 1, 2012
    Posts:
    451
    Thanks guavaman & others :) This has been driving me bonkers since updating to Unity 5 (hadn't seen the error prior) and, while it doesn't break anything, it's simply irritating. As I don't want to risk incompatibilities with web player, etc., I'll skip the patch and will instead be looking forward to the next official release. At least now I know it's not just something screwy with my system or software, so thanks again!
     
  4. Darth_Escar

    Darth_Escar

    Joined:
    Apr 13, 2015
    Posts:
    30
    I get this error with no devices connected except my charger. I'm using a Levono laptop, but I'm not exactly sure what kind. Any idea why I'm getting this???
     
  5. guavaman

    guavaman

    Joined:
    Nov 20, 2009
    Posts:
    5,578
    Did you read the thread? You're getting this because you're using Unity, probably prior to 5.0.1p1. There's nothing you can do to fix it but upgrade to the patch release or wait for 5.0.2. I'm not aware if the 4.x branch has this fix in queue.
     
    boysenberry likes this.
  6. Sutrebla

    Sutrebla

    Joined:
    Sep 16, 2013
    Posts:
    15
    Getting this error in a clean install of Unity 5.01.f1
     
  7. krougeau

    krougeau

    Joined:
    Jul 1, 2012
    Posts:
    451
    Yes, it's fixed in the 5.0.1.p1 patch, not the standard release version 5.0.1f1. It will be fixed in the 5.0.2 version, which hasn't come out yet. Pretty sure this was all gone over in the above posts... Here's a link to the latest patches, if you'd like to install one to fix the issue: https://unity3d.com/unity/qa/patch-releases. Personally, I'm waiting for the next proper release, after all, the message is only a minor nuisance and not worth risking incompatibility with web players, etc.
     
  8. guavaman

    guavaman

    Joined:
    Nov 20, 2009
    Posts:
    5,578
    I think this is the 4th time this info was posted in this thread... Anyway, thanks!
     
    krougeau likes this.
  9. KingfisherWyvernStudio

    KingfisherWyvernStudio

    Joined:
    Oct 5, 2011
    Posts:
    323
    Thanks, @guavaman for keeping us up to date about when this issue will be fixed :) I just ran into the issue (using Unity 5 for the first time and creating terrain for the first in any Unity version :D ), so luckily I found this topic. Now I don't need to worry and I know it will be fixed in one of the coming updates!

    Happy Designing & Coding everyone!
     
  10. Tomasz-TGM

    Tomasz-TGM

    Joined:
    Apr 29, 2015
    Posts:
    3
    Well I guess I'm not getting rid if the RI.His error. And gotta wait for unity 5.0.2 :/
     
  11. guavaman

    guavaman

    Joined:
    Nov 20, 2009
    Posts:
    5,578
    krougeau likes this.
  12. tgraupmann

    tgraupmann

    Joined:
    Sep 14, 2007
    Posts:
    828
    I'm seeing this issue on 5.0.1. Can anyone confirm if it's fixed in 5.0.2?
     
  13. krougeau

    krougeau

    Joined:
    Jul 1, 2012
    Posts:
    451
    Confirmed fixed in 5.0.2 (and documented in the release notes, if you check them). No longer an issue.
     
  14. MisterSkitz

    MisterSkitz

    Joined:
    Sep 2, 2015
    Posts:
    833
    Hello, I've had the same error, but it seems to occur when I save a new scene "as" but don't save the project before running. Strangely enough, after I clear the console and save the project, then run the program, the error message does not return.

    I only have 2 cubes, a unity 3D first person character, and zero scripts, so I can't blame anything other than these objects or what I've suggested.

    However, I don't see a relevance between the error message what I've suggested. Weird!

    Best,

    Duval
     
  15. Deygus

    Deygus

    Joined:
    Aug 14, 2010
    Posts:
    51
    Same Issue Here. I noticed in 5's release and beforehand I didn't have it but now in later releases I am seeing this issue constantly which is really annoying. UE4 never had any of this bs.
     
  16. Demonith88

    Demonith88

    Joined:
    Jun 30, 2014
    Posts:
    216
    I have started empty project and this error shows up i repeat EMPTY project

    Code (CSharp):
    1. <RI.Hid> Failed to create device file:
    2. 2 The system cannot find the file specified.
    3.  
     
  17. guavaman

    guavaman

    Joined:
    Nov 20, 2009
    Posts:
    5,578
    File bug reports. There's nothing else you can do. There is no "fix".
     
  18. jwvanderbeck

    jwvanderbeck

    Joined:
    Dec 4, 2014
    Posts:
    825
    Yep came here for the same reason. I just upgraded to 5.3 from 5.2 and now getting this annoying error :(
     
  19. Captain-Awesome

    Captain-Awesome

    Joined:
    Jul 29, 2014
    Posts:
    28
    I get this error in 5.3.1p1 every time I load a project. But just once, not 320 times like some unlucky people here. :O

    I only notice it because Unity freezes on my about 5 times a day, so I'm reloading my project a lot.
     
  20. Hyp-X

    Hyp-X

    Joined:
    Jun 24, 2015
    Posts:
    421
    Happens on startup in 5.3.2p1.
    Haven't seen this before (last version I used was 5.3.1p3)
     
  21. Luka-NiTL

    Luka-NiTL

    Joined:
    Nov 7, 2013
    Posts:
    7
    Same here, I've been using Unity since 5.1 and I only started getting this error in the newest 5.3.2f1 release
     
  22. avi9111

    avi9111

    Joined:
    Feb 24, 2016
    Posts:
    31
    I have this issue, but not frenquence, and event just one error on the beging by I am runing project. unity4.6 and unity5
     
  23. Dolzen

    Dolzen

    Joined:
    Mar 26, 2014
    Posts:
    90
    I had the same issue, I plugged in my xbox one controller and the it seems to be fixed. The weird issue comes when I try to save an scene when this error happens, scene is not saved I don't know if someone else is experiencien the same behavior as me but plgging in the controller again seems to fix this issue.
     
  24. MANOFSTEEL3D

    MANOFSTEEL3D

    Joined:
    Apr 18, 2016
    Posts:
    3
    not sure if this is the right place to post this,but this is the only thing close to what im getting:just installed unity 5.3.4 for the first time and i continuasly get a freeze every 2 seconds and when in device manager i see a yellow exclamation mark on hid compliant device and the device manager keeps refreshing as if something keeps getting plugged in.i cannot use unity at all because every time it makes that usb plugged in sound,unity freezes for a second but this goes on every 2 seconds for the duration unity is loaded.after i close unity all is back to normal.right now unity is unusable to me.any suggestions?
     
  25. MANOFSTEEL3D

    MANOFSTEEL3D

    Joined:
    Apr 18, 2016
    Posts:
    3
    i have also installed the beta to see and also a 32 bit version of 5.3.4 all do the same thing.completely unusable due to the sound and freeze thing wich happens constantly.i really need help fixing this.unable to even do anything in unity right now,all it does is freezes-unfreezes each second and makes the usb plugged in sound.took out some hardware still npthing(wifi adapter and usb 3 pci connector,unplugged my usb speakers,keyboard,mouse.if i cant fix this then its no unity at all for me:(
     
  26. guavaman

    guavaman

    Joined:
    Nov 20, 2009
    Posts:
    5,578
    I would contact Unity support and start a new thread. This thread is not about your issue and posting this here is just going to take over the thread if you get responses. The "failed-to-create-device" message does not cause the problems you describe and isn't caused by a bad device in the device manager. It's a largely cosmetic bug in Unity's handling of Raw Input devices that was fixed at some point in the past but has regressed in recent versions of Unity.
     
  27. MANOFSTEEL3D

    MANOFSTEEL3D

    Joined:
    Apr 18, 2016
    Posts:
    3
    ok sorry my bad posting it here.if an admin would delete my post so to not confuse the thread thats fine by me.btw thx for answering.you have pointed me in a direction i can persuit at least(device manager)
     
  28. kburkhart84

    kburkhart84

    Joined:
    Apr 28, 2012
    Posts:
    910
    I also get the error upon startup.
    It shows up 3 times, and I had never seen it before. I'm sure it is caused by a few USB control pads I have. I just bought 3 of these Sabrient Blue gamepads that I found at Frys, they look like Logitechs, with 6 face buttons, like playstation dual-shock but 6 face buttons(and no analog LR triggers, rather just 2 of each LR). It is too coincidental to believe it isn't caused by that.

    Now, I haven't done any extensive testing, but the errors seem to go away and not come back when I hit play. The controllers aren't connected at the moment, as me and the kids were just using them for some emulation gaming goodness. In any case, my current project is primarily mouse based(a missile command clone but with lots of other stuff in there) so I don't it will bother me unless it somehow ends up causing problems in builds.
     
  29. CAD97

    CAD97

    Joined:
    Mar 11, 2015
    Posts:
    4
    I'm getting the error

    Code (csharp):
    1. <RI.Hid> Failed to create device file:
    2. 2 The system can not find the file specified.
    a single time on startup (5.3.4f1).

    It seems to be caused by having previously had a controller connected; before I ever connected my XBox controller, this error didn't show up, and now, whenever I don't have the controller connected, this error shows on startup.

    Likely the Unity Editor saved somewhere that it expects a controller to be connected, and when it isn't, the OS returns a "no file" for whatever it's looking for that indicates the controller, and rather than gracefully handle that as a lack of a controller, it regressed to just burping out this error.

    Thankfully, it seems fully cosmetic in its current form and only shows up a max of once per controller you've ever had plugged into the project, only on initial startup. Here's to hoping that the Unity team patch this back out in the near future!
     
    thegreatzebadiah and Caligari like this.
  30. Czar-Man

    Czar-Man

    Joined:
    May 10, 2013
    Posts:
    20
    I found out that I got this error because I was using a First-Person Controller prefab and forgot to remove the default Main Camera. When I did remove it, the problem was gone.
     
  31. coltonhurst

    coltonhurst

    Joined:
    Jun 27, 2014
    Posts:
    2
    I have Unity 5.3.5f1 and I'm getting the <RI.Hid> error also that people have posted above. Has there been a fix? How can I run unity with it or get rid of the error? Please help.
     
  32. The-Mec

    The-Mec

    Joined:
    Nov 21, 2013
    Posts:
    9
    i'm getting this error as well with 5.3.5f1
     
  33. Cross22

    Cross22

    Joined:
    Sep 26, 2014
    Posts:
    22
    Still broken in 5.4.0f3
     
  34. Protozoaire

    Protozoaire

    Joined:
    Apr 14, 2015
    Posts:
    61
    Just opened case 824401. Waiting for an hotfix.

    Unity 5.4.0f3 (64-bit)
    1) Connect the Wireless Xbox One Controller from Oculus Rift package
    2) Launch Unity
    3) Error message in Console:
    <RI.Hid> Failed to create device file: 2 Le fichier spécifié est introuvable. (File not found)
    => Controller is not detected
    4) Turn off the controller, then turn it on.
    Message in console:
    Joystick connected ("Controller (Xbox One For Windows)").
    => Controller is detected

    We can't tell people to turn controller off, then on, every time they launch the game.

    It's a major bug because every Unity games I've played have that issue.
    Not present on Oculus Home or non-Unity games (controller is detected).

    Examples :
    - Controller not detected on VR Goat (Oculus Store).
    - Controller detected on Minecraft and Oculus Store.

     
    Last edited: Aug 19, 2016
  35. Protozoaire

    Protozoaire

    Joined:
    Apr 14, 2015
    Posts:
    61
  36. jlmakes

    jlmakes

    Joined:
    Jan 7, 2016
    Posts:
    1
    Windows 10 (64-bit)
    Unity 5.4.0f3 (64-bit)
    Playstation DS4 Controller (USB)

    I solved this issue by ensuring that DS4Windows was running before opening Unity. If you're familiar with using a DS4 on Windows, you'll know this application is required before use in games anyway -- it's no different for Unity.
     
  37. Creative-House-org

    Creative-House-org

    Joined:
    Nov 13, 2015
    Posts:
    4
    Nope... Still got the issue :S

    As you can see i'm getting the same in my Unity running DS4Windows:


    In case if anyone is wondering what version i am using:


    Any "input" on this would be great! :p

    Thanks in advance!
     
  38. DCrosby

    DCrosby

    Joined:
    Jan 13, 2013
    Posts:
    86
    I just wanted to report that the Interlink Controller from Futaba, that simulates RC Controls for Helicopters, and Airplanes was at fault with me, as soon as I unplugged it, everything else was fine.
     
  39. yangamedev

    yangamedev

    Joined:
    Apr 16, 2016
    Posts:
    1
    I have a PS3 controller connected to my machine, this error goes away when I run SCPServer in the background to enable its use.
     
    hexagonius likes this.
  40. aiden_carter

    aiden_carter

    Joined:
    Nov 17, 2016
    Posts:
    1
    The Long path tool is the very best program for error, unlock solution.
    Try it and solved your problem.
    I used the long path tool and I solved my error, unlocks problem solution.
     
  41. pointcache

    pointcache

    Joined:
    Sep 22, 2012
    Posts:
    576
    So will this ever be fixed? How many more years to wait?
     
    TPG-Bernhard likes this.
  42. Fergicide

    Fergicide

    Joined:
    Mar 19, 2016
    Posts:
    21
    I'm on 5.4.1-f1 and I started getting it a few days ago in an established project. No usb devices or controllers connected. Only getting it on project load.

    <RI.Hid> Failed to create device file:
    2 The system cannot find the file specified.
     
  43. HalversonS

    HalversonS

    Joined:
    Jan 24, 2014
    Posts:
    28
    Back in 5.6.0f3. After update to newest version "<RI.Hid> Failed to create device file:
    2 The system cannot find the file specified."
    has begun appearing. No changes to what I have plugged in. I'll try deleting my local library... but just a heads up.

    Edit: deleting library and player settings has no effect on the issue. Also unplugging all usb devices and rebooting has no effect.
     
    Last edited: May 2, 2017
  44. DarkDeivel

    DarkDeivel

    Joined:
    Aug 31, 2016
    Posts:
    127
    Help! This problem has appeared and I have now!

    [Unity5.6.0f3]
     
  45. Lorin_Atzberger

    Lorin_Atzberger

    Joined:
    Dec 11, 2013
    Posts:
    119
    Same in 5.6.2f1. I usually turn the monitor off when I go to sleep and when I come back I only have to turn it on. I always get a couple of these over the night. I don't even have a controller connected. The only odd hardware item is a graphical tablet.
     
  46. davidpets

    davidpets

    Joined:
    Sep 13, 2017
    Posts:
    1
    I see this frequently in v2017.1.1f1 also.
     
  47. xSoloxZ32x

    xSoloxZ32x

    Joined:
    Oct 20, 2017
    Posts:
    4
    I don't have any game controllers plugged in but I do have a MIDI controller for audio production plugged in and turned off. I get this error once when Unity loads up but after I clear the console it doesn't show up again. I'm just curious if it has anything to do with the MIDI controller. And could I play a game with a MIDI controller? haha
     
  48. hedgefield

    hedgefield

    Joined:
    Jan 1, 2014
    Posts:
    39
    Just started happening to me in 2017.3. After I plugged in a dualshock 4 for the first time (and unplugged it again) it's been saying this when I start Unity ever since.
     
  49. artics

    artics

    Joined:
    Sep 17, 2013
    Posts:
    8
    still no fix...
     
  50. GfK

    GfK

    Joined:
    Aug 15, 2014
    Posts:
    107
    It's been UNfixed in 5.6.5p1!

    Started getting this error today. Suspect (with little evidence to support the theory) that it might be because I had my Xbox One controller attached when I last saved/closed my project, but it wasn't connected when I reopened the project later.

    Can see no adverse effect to receiving this error at the moment so I guess we can just call it a minor irritation?

    [update]

    OK... every time I start my project with no controllers, I get this error.

    If I plug my Xbox One controller in (as it was when I last saved), THEN open Unity, the error doesn't happen. So I guess it's simply down to the controller availability/configuration changing between save/startup. With that in mind I guess it would make no difference at all to a released game so, really no biggie.
     
    Last edited: Jan 23, 2018