Search Unity

  1. Improved Prefab workflow (includes Nested Prefabs!), 2D isometric Tilemap and more! Get the 2018.3 Beta now.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. Let us know a bit about your interests, and if you'd like to become more directly involved. Take our survey!
    Dismiss Notice
  4. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice
  5. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice

Render Jitter with Multiple Camera Setup (See Video)

Discussion in 'General Graphics' started by FirstTimeCreator, Oct 11, 2018.

  1. FirstTimeCreator

    FirstTimeCreator

    Joined:
    Sep 28, 2016
    Posts:
    651
    I have been working on this issue for a while now and I can't seem to solve it.

    I have
    -checked my hz on monitor
    -Made the build exclusive fullscreen
    - RigidBody is interpolated
    - All physics movement is in FixedUpdate
    -I have limited FPS to 50.
    -I removed everything from the scene for except a few low poly objects, the draw call is under 100.

    I don't think this issue is related to physics, the ships appears to move smoothly and there is no jitter in the first depth camera as you can see the ship and UI do not jitter.

    The second depth camera and the skybox camera appear to momentarily jitter. I think I have isolated this to a rendering problem and not a physics timing problem.

    Also, you can see in the video that when it jitters there are sometimes blanks (black image renders) appearing in the render. I am recording the video at 60 FPS to catch all frames.

    Does anyone have experience with a render jitter with a multiple depth camera and skybox setup?

     
  2. FirstTimeCreator

    FirstTimeCreator

    Joined:
    Sep 28, 2016
    Posts:
    651
    Update:

    Well I just solved it, or at least completely eliminated it.

    I turned on triple buffering, vsync half through NVIDIA driver control panel.

    If triple buffering is an issue, is there a way to enable it through C# or some sort of Nvidia API ?

    I can't seem to find a way outside of the nvidia control panel but there must be some way right? Requiring users to go do some manual setup before running your game is not .. a good scenario.
     
    Last edited: Oct 11, 2018
  3. FirstTimeCreator

    FirstTimeCreator

    Joined:
    Sep 28, 2016
    Posts:
    651
    So unity Vsync fixes it for the most part, it's still there but barely noticeable if you aren't looking for it. NVidia's adaptable vsync option appears to completely fix it.