Search Unity

Render in Hybrid Renderer V1 but not in V2 using minimum target machine specs

Discussion in 'Graphics for ECS' started by Armitage1982, Feb 22, 2022.

  1. Armitage1982

    Armitage1982

    Joined:
    Jul 26, 2012
    Posts:
    38
    Hi,

    I'm using Hybrid Renderer v2 in URP 10.8.1 from Unity 2020.3.29f1 and trying to build a Windows 10 executable supporting up to Intel HD 3000 (gen. 6).

    Everything render correctly in any recent devices, but Hybrid converted GameObject refuse to render on Intel HD 3000 (Windows 10 Macbook Air mid-2011).

    However the rest of the scene, regular static objects, renders correctly. I can even hear the sound caused by collisions made with Havok, so I know my Entities are working and present.

    The supported graphic API is DX11, shader model is 4.1 and from system requirements I don't see what could be the problem?

    I tried to uncheck "Enable GPU Instancing" on all material and build with an without the SRP Batcher on Hybrid Renderer V2 but still no rendering on these converted GameObject.

    I tried to build the same project under Hybrid Renderer V1 (by removing the Compilation condition and unchecking SRP Batcher) and there everything works correctly, I can see the objects.

    This is rather strange when you know that I only use URL/Lit materials with a Reflection Probe while they are marked as Not Supported in the Hybrid Renderer V1.

    On a side note, using Havok, there are 3 shaders present in "Unity Physics/Unity.Physics/Hybrid/Assets/DebugDisplay/Resources/" which uses #pragma target 4.5. As they are not supported by this Graphic Card I created a Custom Package for Unity Physics (by, for those like me who didn't know it was possible, duplicating the package folder from Library\PackageCache to the Packages folder) in order to target 4.0.
    I don't know if this will have an impact in the future, but, just in case, I'm throwing this here.


    For now, I'll continue with the Hybrid Renderer V1, but if you know how I could fix these problems in V2, I'd appreciate it.

    I also test all this on an older Intel Pentium 3556U featuring an Intel HD (gen 4) on a laptop PC, and I don't have this problem.
    Would that mean that a Windows 10 on a 2011 Macbook Air is a too exotic configuration to work with this pipeline?


    Needless to say, all my drivers are up-to-date, C++ redist 2017 has been installed for Havok, Windows is up-to-date and everything is functional.
     
  2. JussiKnuuttila

    JussiKnuuttila

    Unity Technologies

    Joined:
    Jun 7, 2019
    Posts:
    351
    Hybrid Renderer V2 requires Shader Model 4.5 (compute shaders), and will not work on anything less than 4.5.
     
  3. Armitage1982

    Armitage1982

    Joined:
    Jul 26, 2012
    Posts:
    38
    Yeah, you are right.

    I double-checked and Intel Pentium 3556U is equipped with an Intel HD Graphics (Haswell) featuring a Shader Model 5.1, while the Intel HD 3000 is only 4.1 (and so no ComputeBuffers I guess).

    Thanks for the clarification, It would be helpful to add it to the system requirements in the manual.