Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Removing "read-only" from Animation Clips?

Discussion in 'Animation' started by desmond96, Jan 27, 2018.

Thread Status:
Not open for further replies.
  1. desmond96

    desmond96

    Joined:
    Jan 9, 2018
    Posts:
    2
    Hello Guys!

    So I have a model with already existing animations that I wanted to use. Those also work perfectly fine, but I would still like to edit some of them.. which I can't, since all clips are in "read-only" mode and I really have no idea how to fix this. I was reading that copying the animation clip with CTRL+D would fix it, but creating a copy doesn't even work.

    The model file and the animation files were also in a .smd format at the beginning. So what I did was:

    - Importing the model and the animations into blender
    - Exporting them together as one fbx file
    - Importing it again to Unity

    So as I said, the animations work fine with the model, but I'd LOVE to remove this "read-only" part, since it bothers me now for a long time..

    Help would be appreciated a lot! c: View attachment 264216 View attachment 264216
     
  2. theANMATOR2b

    theANMATOR2b

    Joined:
    Jul 12, 2014
    Posts:
    7,790
    I believe you can turn off read-only by going into debug mode - check documentation to learn more about debug mode.

    For future animation edits - strongly consider editing in a 3D software package like blender, 3D Max or Maya.
    This will save you hours of frustration, compared to animation editing in Unity.

    BTW - if these are humanoid setup animations you will not be able to edit and keep the changes in Unity. Humanoid setup is for imported animations, not internal edited/created animations.
    You will have to use the generic rig instead to allow for in engine editing.

    There are tools available in the asset store to overcome this mecanim restriction, but I've never used any of them so I can't say how they work, how user friendly they are.
     
    vamosfa likes this.
  3. theANMATOR2b

    theANMATOR2b

    Joined:
    Jul 12, 2014
    Posts:
    7,790
    Hard to say - probably the rig defaulted to humanoid and you didn't set up an avatar properly, but that is a wild guess based on very limited information.
    Consider strongly working through the animation training/learning material in the learn section. This will give you a great base to proceed.
     
    jsn2001 likes this.
  4. davejas

    davejas

    Joined:
    Apr 12, 2017
    Posts:
    5
    I've since learned a very easy way to remove read-only...

    1. Select the animation in your assets folder
    2. Expand the file with the little arrow in the circle
    3. Select the animation itself, the icon with the play button
    4. Press Command-D (on Mac)

    This will create a duplicate of that file that is no longer read-only!

    Screen Shot 2018-02-08 at 6.21.05 PM.png
     
  5. unity_XY9GfkpHMyaikw

    unity_XY9GfkpHMyaikw

    Joined:
    Oct 16, 2018
    Posts:
    2
    It didn't work . I lose the avatar.
     
    nailmail likes this.
  6. DaveMero

    DaveMero

    Joined:
    Nov 4, 2017
    Posts:
    15
    If have the same Problem. If i try to duplicate it i get an error: ArgumentException: Ilegal Charakters in path. What is that meaning?
     
  7. DaveMero

    DaveMero

    Joined:
    Nov 4, 2017
    Posts:
    15
  8. intellime

    intellime

    Joined:
    Mar 18, 2018
    Posts:
    14
    It is OK, just click on the avatar icon and select one of the options:
    upload_2019-5-29_16-5-43.png

    upload_2019-5-29_16-7-33.png

    If you want to use your own model, so click 'Other...' and then select the FBX file which is already contains your avatar.
     
  9. anthonycavuoti

    anthonycavuoti

    Joined:
    Aug 7, 2018
    Posts:
    2
    Life Saver. Thank you!!!
     
  10. KienHung

    KienHung

    Joined:
    Jan 16, 2017
    Posts:
    1
    Thank you very much.
     
  11. EvilGremlin

    EvilGremlin

    Joined:
    Aug 12, 2016
    Posts:
    231
    The animations are still read only when I ctrl D them...
     
    filip-mixedworld likes this.
  12. zeropointblack

    zeropointblack

    Joined:
    Jun 8, 2020
    Posts:
    197
    worked for me. thanks. was an animation imported from mixamo with an avatar included.
     
    ortizelvis825 likes this.
  13. advo

    advo

    Joined:
    Apr 6, 2016
    Posts:
    14
    @zeropointblack Did you realize that after duplicating the animation just so that you could edit it, that the duplicated animation blows up the file size ? Check it in your file explorer.

    My original imported single animation from Mixamo (without skin) was 1MB+. I duplicated it as i wanted to remove part of the animation (e.g. removed the head and neck movements). But i realized the duplicated animation file was 10MB +... and thats for ONE animation!

    Anyone running into this issue? Isn't this going to blow up the size of the build?
     
  14. zeropointblack

    zeropointblack

    Joined:
    Jun 8, 2020
    Posts:
    197
    yeah, now that you mention it, im noticing my .anim files are a bit bigger than the .fbx versions.

    i thought maybe because the fbx can be set to optimize the key frames, but then i checked the original fbx files, before unity, and they also are the same small file size. so no idea whats going on there, unless the .anim process is adding more frames or keys somewhere.

    for me its not that much. maybe a jump from 325kb to 4 megs. pretty big difference, yeah, but still small enough not to worry about.

    yeah, anyone know whats up?
     
  15. Shams_new52

    Shams_new52

    Joined:
    Nov 1, 2019
    Posts:
    1
    thanks @davejas. this was really helpful. i downloaded some animations from mixamo, and unity was giving them as "Read-only" type. now, its gone and i can use its options. as well as put some events in the frames.
     
  16. aloneandsuffering101

    aloneandsuffering101

    Joined:
    Apr 21, 2018
    Posts:
    15
    Duplicating works, but anyone know why this happens in the first place or how to fix it without having to duplicate dozens and dozens of animation files?
     
  17. shaharyarazhar

    shaharyarazhar

    Joined:
    Feb 15, 2021
    Posts:
    1
    I think by creating a duplicate file of read-only file, By Select, the animation in your assets folder then Expand the file with the little arrow in the circle, Select the animation itself, the icon with the play button Press Command-D (on Mac).
     
  18. npatch

    npatch

    Joined:
    Jun 26, 2015
    Posts:
    235
    This is how I understand it.

    The animation in the fbx is in binary form. The animation clip Unity creates from importing the fbx lies inside the Library folder and you don't need to look for it as it's ReadOnly, and it makes it easier for the Importer to handle everything, without the user messing with the resulting file. If you duplicate the animation from the fbx, that creates a second file(beside the fbx since that's how you'd look for it), but since it's a Unity anim clip, it's not longer in fbx format, but in .anim which is YAML, which if you have text serialization, means it's a text file. Text files tend to be larger than the equivalent data in binary form, more so if the serialization format used (e.g. YAML) is verbose( has more stuff written to keep track of links etc).

    Same thing happens with fbx after import in Unity. If you navigate to the folder, you only see the fbx and its meta file. But in the Project window, it shows like a prefab(with a thumbnail etc). The prefab lies in the Library folder. If you create a prefab variant based on the fbx, again it's a Unity structure, therefore will be serialized in a YAML file. This one will be visible the file explorer, contrary to the prefab made by the fbx.

    It also explains how the Library folder gets that big in no time.
     
  19. SupremePanda

    SupremePanda

    Joined:
    Mar 9, 2019
    Posts:
    3
    Today it is end of the 2021, and it is only solution to edit read only animations. Thanks!
     
    akast07 and ortizelvis825 like this.
  20. Rispat-Momit

    Rispat-Momit

    Joined:
    Feb 14, 2013
    Posts:
    263
    You are amazing :)
     
  21. KalOBrien

    KalOBrien

    Administrator

    Joined:
    Apr 20, 2021
    Posts:
    89
    locking now as its been answered
     
Thread Status:
Not open for further replies.