Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. Join us on Dec 8, 2022, between 7 am & 7 pm EST, in the DOTS Dev Blitz Day 2022 - Q&A forum, Discord, and Unity3D Subreddit to learn more about DOTS directly from the Unity Developers.
    Dismiss Notice
  3. Have a look at our Games Focus blog post series which will show what Unity is doing for all game developers – now, next year, and in the future.
    Dismiss Notice

Bug Reload script assemblies stuck

Discussion in 'Editor & General Support' started by zenwatermelon168, Sep 16, 2022.

  1. zenwatermelon168

    zenwatermelon168

    Joined:
    Sep 23, 2020
    Posts:
    6
    I've been dealing with this issue for months now. I'm developing VR game using OpenXR. This happens randomly midway working on project. Even when it was working just fine before with no code changes.

    Whenever pressing play, the reload assemblies will pop up for 5 seconds, and the Editor will freeze. No error.
    Task Manager shows the Editor is not responding. Sometimes if I wait long enough the scene might play.

    I've tried for hours to find the cause of this. There is no common cause for this issue between my projects. Sometimes removing specific packages like OpenXR and Oculus will fix it, but sometimes it will not. I am working on 4 different projects (subsystems of the game) with different external packages, so it is unlikely related to external packages.

    I've just been dealing with this by transferring all my files to a new project. Which will work for a while, but eventually the freeze will come back after a week. This issue is literally driving me nuts. I've switched between multiple Unity versions 2019 2021 and 2022. but that does not seem to fix this issue. I've tried reimporting all, deleting caches, using different renderers, removing packages one by one. It also happens in empty scenes.

    I have 16GB RAM, RTX 3070, Ryzen 5 3600. I also have plenty of storage.

    This is the Log.
    Freezes on [Subsystems] Loading plugin UnityOpenXR for subsystem OpenXR Display...

    I've also uploaded the full log.


    UPDATE
    So I've narrowed down the issue to maybe the OpenXR plugin. I've removed it, and it worked. And then reinstalled it, and it still works. But I know that this issue will eventually come back. What do I do now?

    UPDATE 2:
    Project is broken again when importing new scripts/assets.
     

    Attached Files:

    Last edited: Sep 16, 2022