Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice

[released] Fullscreen Editor

Discussion in 'Assets and Asset Store' started by MukaSchultze, Apr 14, 2019.

  1. Fibonaccov

    Fibonaccov

    Joined:
    May 5, 2020
    Posts:
    58
    Nice. May I ask how got the hierarchy panel + tools minibar on full screen editor view? I can't get the hierarchy panel to appear in full screen editor scene view (F11).
     
  2. MukaSchultze

    MukaSchultze

    Joined:
    Feb 12, 2014
    Posts:
    256
    I know this isn't the best option, but if you create a new container with the scene and hierarchy windows you can use the "Focused Fullscreen" (usually F9) to create a fullscreen that has both of them

    upload_2020-10-30_9-46-17.png
     
    Fibonaccov likes this.
  3. Fibonaccov

    Fibonaccov

    Joined:
    May 5, 2020
    Posts:
    58
    Thank you Muka. The way I was doing it until now was to drag and drop the Hierarchy panel into the scene view and then pressing F11. Going to try the container approach too. Cheers
     
  4. WILEz1975

    WILEz1975

    Joined:
    Mar 23, 2013
    Posts:
    375
    It is not possible at the moment. I created an image using photoshop to make the idea;)
     
  5. AGregori

    AGregori

    Joined:
    Dec 11, 2014
    Posts:
    527
    As someone mentioned, using Peek on top of Fullscreen Editor does the job 100%. Of course, that asset is 3 times the price of FE to begin with.
     
    Fibonaccov and Lars-Steenhoff like this.
  6. Fibonaccov

    Fibonaccov

    Joined:
    May 5, 2020
    Posts:
    58
    Well, besides what I mentioned above which is to drag and drop the hierarchy panel inside the scene view and then press F11, it works - the other way is Shift+Space while hovering the mouse cursor in the scene view and then Ctrl+4 to bring up some hierarchy panel within the maximized (windowed) scene view - this will also have the tools bar. Or purchase Peek or the container approach as mentioned priory.
     
  7. MukaSchultze

    MukaSchultze

    Joined:
    Feb 12, 2014
    Posts:
    256
    What do you guys think would be the best way of doing this? Perhaps adding a new shortcut or an option in the settings?
     
  8. Fibonaccov

    Fibonaccov

    Joined:
    May 5, 2020
    Posts:
    58
    Yes, I think adding an option in the settings would work great - one could always dismiss the hierarchy windows / panel if one would not want to have it when scene view is maximized and enabled setting is turned on.
    I tried pressing Ctrl+4 with FE with the scene view maximized but it does not do anything - Ctrl+4 only shows when maximizing using Shift+Space.
     
  9. LaserRock

    LaserRock

    Joined:
    Jan 2, 2018
    Posts:
    13
    How I can make fullscreen work with xbox game bar or OBS?
     
  10. MukaSchultze

    MukaSchultze

    Joined:
    Feb 12, 2014
    Posts:
    256
    It currently doesn't work with XBox Game Bar. For OBS you must change the source to "Display" instead of "Window", as shown here
     
  11. Singtaa

    Singtaa

    Joined:
    Dec 14, 2010
    Posts:
    493
    It seems 2020.1.14f1 got rid of UnityEditor.GameView.GetMainGameView again?... For people experiencing the issue, here's a temp work-around:

    Code (CSharp):
    1. /// <summary>Get the main game view.</summary>
    2. public static EditorWindow GetMainGameView() {
    3.     return Types.WindowLayout.InvokeMethod<EditorWindow>("FindEditorWindowOfType", Types.GameView);
    4. }
     
  12. MukaSchultze

    MukaSchultze

    Joined:
    Feb 12, 2014
    Posts:
    256
    Check on the preferences page that the plugin version matches the latest version (v2.2.2). The current package manager has a bug where it downloads older versions of assets. I had a few other users with the same problem.

    upload_2020-11-21_2-2-24.png

    Let me know if that's not the issue,
    Thanks for the feedback.
     
  13. DrummerB

    DrummerB

    Joined:
    Dec 19, 2013
    Posts:
    139
    Hi! Awesome tool! Works perfectly out of the box.

    One question:
    What is the "At mouse position" mode supposed to do? I assumed it would determine what monitor to use by checking where the mouse is. But for me, it seems to always use the main display.
    I'm on Windows 10, Unity 2020.2b12, Fullscreen 2.2.2
     
  14. MukaSchultze

    MukaSchultze

    Joined:
    Feb 12, 2014
    Posts:
    256
    It is supposed to open on the screen where the cursor is, this is certainly a bug. I'll see if I can reproduce the issue here.
    Thanks for the report!
     
  15. DrummerB

    DrummerB

    Joined:
    Dec 19, 2013
    Posts:
    139
    Thanks! I think the problem is that the mouse position is not reported correctly when the cursor is not above Unity. It seems to stop updating and reports the last position above the Unity window. Using Input.mousePosition, instead of FullscreenUtility.MousePosition fixes it, but only in Play mode, hmm... I hope you find a solution, but if not, it's not a huge issue for me. I can set it to always use the secondary display, I just thought using the mouse position would be more flexible.
     
  16. DrummerB

    DrummerB

    Joined:
    Dec 19, 2013
    Posts:
    139
    It seems that the mouse tracking indirectly causes another issue. You repaint the Project and Hierarchy windows every half a second (as far as I understand, this is done to update the mouse position). However, if you have a lot of folders or objects in those windows, this can cause some very noticeable performance spikes.

    Screenshot_2020-11-21_22-10-11.png

    If I remove the EditorApplication.update hook, this is fixed.
     
  17. Singtaa

    Singtaa

    Joined:
    Dec 14, 2010
    Posts:
    493
    @MukaSchultze You are right! It's the Package Manager bug. No matter how many times I update the package, it always go back to an older version. Had to manually delete the cached version on disk to fix.
     
  18. MadStuntman

    MadStuntman

    Joined:
    Jun 27, 2019
    Posts:
    25
    @MukaSchultze Mouse input for fullscreen Game View isn't work in 2020.2.1f1. Fullscreen 2.2.2, default settings.
    Tested in the real project as well as in the newly created default project.
    Changing of "At mouse position" to "Main Display" in the preferences didn't help. Last version where it works fine is 2020.1.17f1.

    Any ideas how to fix it? Thanks in advance!
     
  19. MukaSchultze

    MukaSchultze

    Joined:
    Feb 12, 2014
    Posts:
    256
    It's a known issue, there's already an experimental fix for it, mail me your invoice number and I'll send you the updated package.
     
  20. MadStuntman

    MadStuntman

    Joined:
    Jun 27, 2019
    Posts:
    25
    Invoice number sent. Thank you!
     
    MukaSchultze likes this.
  21. AGregori

    AGregori

    Joined:
    Dec 11, 2014
    Posts:
    527
    @MukaSchultze I also send you my IN#, I need the patch, thanx.
     
    MukaSchultze likes this.
  22. MikeUpchat

    MikeUpchat

    Joined:
    Sep 24, 2010
    Posts:
    1,056
    I used your great asset when I was helping on a project, it worked great, but we did notice that for some reason we were getting regular spikes in the profiler when your asset was installed, if we deleted your asset and restarted Unity the spikes were gone. I was hoping to get this asset for my own project but the spikes are putting me off a bit, is this something you have seen at all?
     
  23. MukaSchultze

    MukaSchultze

    Joined:
    Feb 12, 2014
    Posts:
    256
    It's a known issue, this is caused by the way the plugin calculates the mouse position. These spikes can be disabled by removing some code, and there'll be an option for disabling this in the upcoming version.
     
    EyeSeeEm likes this.
  24. AGregori

    AGregori

    Joined:
    Dec 11, 2014
    Posts:
    527
    @MukaSchultze Unfortunately, even with the latest (2.2.3?) patch, Fullscreen Editor creates huge lags in the workflow on Unity 2020.2.3.
    I guess it's the same issue MikeUpChat is talking about.
    Please specify the code to be removed, or create a new patch, thanks.
     
  25. MukaSchultze

    MukaSchultze

    Joined:
    Feb 12, 2014
    Posts:
    256
    Comment out lines 95 and 96 of
    Fullscreen\Editor\FullscreenUtility.cs
    , I'm still trying to figure out the best solution though, let me know if this works for you.
     
    AGregori likes this.
  26. woowee

    woowee

    Joined:
    Jul 1, 2017
    Posts:
    10
    Does this support secondary monitor on Mac now? I need to know before I buy...
     
  27. MukaSchultze

    MukaSchultze

    Joined:
    Feb 12, 2014
    Posts:
    256
    No, macOS support is still very limited. Sorry about that.
     
  28. MattRix

    MattRix

    Joined:
    Aug 23, 2011
    Posts:
    121
    I am currently having an issue where the mouse scrollwheel does not work in Fullscreen mode. Otherwise the mouse (clicking and dragging etc) seems to work fine.
     
  29. MukaSchultze

    MukaSchultze

    Joined:
    Feb 12, 2014
    Posts:
    256
    What Unity version you're using? I'll try to reproduce it here.
     
  30. MattRix

    MattRix

    Joined:
    Aug 23, 2011
    Posts:
    121
    This is with Fullscreen 2.2.2 in Unity 2020.2.5f1 on Windows 10 - I get nothing from Input.mouseScrollDelta the moment I go fullscreen in the game view. Mouse wheel still works fine if I put the scene view into fullscreen mode, so it's only a game view issue.
     
  31. MukaSchultze

    MukaSchultze

    Joined:
    Feb 12, 2014
    Posts:
    256
    I was able to reproduce it, can you mail me your invoice number so I can send you a beta version with a possible fix?
     
  32. MattRix

    MattRix

    Joined:
    Aug 23, 2011
    Posts:
    121
    Thanks for your help! This really is a great plugin.
     
  33. Zartok

    Zartok

    Joined:
    Apr 21, 2017
    Posts:
    4
    Hello there, I have tried some different settings now, but whenever I press the fullscreen button it is zoomed in. I'm using a 2k resolution on my screen and I tried every aspectratio. Anyone else experience this problem?
    The picture below shows how it is suppose to look, and what the fullscreen shows
     

    Attached Files:

  34. MukaSchultze

    MukaSchultze

    Joined:
    Feb 12, 2014
    Posts:
    256
    Hi, this has been reported before but I couldn't reproduce it in my environment, do you mind sharing some info about your setup? I need your Unity version, OS, screen resolution, screen count, and display scaling (if you're using any).

    As a possible workaround, you can go to the preferences and change the
    Placement source
    to
    Window Display
    or
    Display 1
    , let me know if this works for you
     
  35. Zartok

    Zartok

    Joined:
    Apr 21, 2017
    Posts:
    4
    Awesome response time :) Ok, lets see:
    -Unity version: 2019.4.25f1
    -OS: Windows 10
    -Screen resolution 2560x1440
    -Only one main screen
    -Display scaling none (100%)

    Tried using placement source as both Display 1 and Main Display

    The focus view works well in every window but the Game one. Same happends in both play mode and edit mode.

    Ok good news, it seems that the fix now was to set the placement source to Window Display, then spesificly set the display resolution inside unity to the same as my windows resolution :) I guess that means there is some problem between the unity scaler and the scaler in the asset?
     
  36. MukaSchultze

    MukaSchultze

    Joined:
    Feb 12, 2014
    Posts:
    256
    upload_2021-5-12_14-11-41.png

    You're changing using this box, right? This isn't changed automatically, it keeps the resolution selected prior to opening the fullscreen, this is by design because most users change this and expect the fullscreen to have the same selected resolution.

    On the other hand, that out-of-bounds issue, where part of the window is off-screen, is definitely a bug, it possibly has something to do with the monitor DPI. I'll test it out with a higher resolution screen and try to reproduce it again.

    Thanks for the feedback and the info about your system.
     
  37. GrassWhooper

    GrassWhooper

    Joined:
    Mar 25, 2016
    Posts:
    113
    `hello, so i am on linux (ubuntu 20.04) and every time ,i try to enter full screen mode in game, i end up with this.
    i tried using Main Window, and other settings but non work properly
    the closest one to work properly was the at mouse position, but then, i have to exactly place my mouse in the center of the screen so it shows at the entire screen.
    extra note, even using the at mouse position, the tool bar at the top, never vanishes, i tried to use hide global, but still to no avail any ideas?
    extra notes:
    i have both nautilus and nemo file managers installed
    i also have wmctrl installed, but i assume, that, any of these file managers support the needed elements, even if only one of them.

    Image of how it works

    https://drive.google.com/file/d/12kMn0dGFBYlqXHYSOgzG9_UGQgjT6kfT/view?usp=sharing
     
    Last edited: May 15, 2021
  38. MukaSchultze

    MukaSchultze

    Joined:
    Feb 12, 2014
    Posts:
    256
    What Unity version are you using?

    but then, i have to exactly place my mouse in the center of the screen so it shows at the entire screen.


    Can you explain more about this? What happens when the mouse is not at the center? This should not affect the overall result as long as the pointer is on the screen, no matter where.

    This might be the same issue as the one reported above. Please send me your screen resolution and screen count so I can pinpoint this issue.

    The toolbar at the top is a separate issue, I've seen it happen on Ubuntu before, don't it happens with other fullscreen applications as well? It can be changed in the OS preferences as far as I remember.
     
  39. GrassWhooper

    GrassWhooper

    Joined:
    Mar 25, 2016
    Posts:
    113
    Unity 2019.4.16f1

    2 monitors, each one is 1600x900.
    it was not working on the 2 screen setup, so i went and changed my monitors settings to "Mirrored" so they should have been acting the same.

    to be fair, i thought the "displacement" of the monitor (as in the screenshot), was caused due to mouse not being exactly on center of the screen.

    Note: i did attempt to change my mouse position to the other screen (i disabled mirrored mode), and nothing changed, the full screen only pops on main (even though i changed mode in preferences).

    ok, so, i did manage to get it working on somehow, at least on one monitor.

    basically, i had to install an extension called
    https://extensions.gnome.org/extension/545/hide-top-bar/

    which hid the top bar, then i assigned the preferences to the following

    "Mode: At Mouse Position" (noting that, regardless of where the mouse position is, it doesn't matter it always full screens onto the main monitor, and noting that, it doesn't matter on which monitor the unity editor is, full screen will still always go to main monitor.

    now, after full screening (F10) it works fine, but, if i minimize and full screen again, it doesn't work (full screen goes behind the unity editor
    when that happens, i click (F8), to make sure, the exit/minimize buttons of the editor do show up, then if i press (F10) it maximizes successfully.

    there are some nasty bugs on linux, but i guess that is to be expected :'( at least, i got it to work on some form or another at least, thanks for the help, and i do hope these things get fixed in the future for linux too.
     
  40. MukaSchultze

    MukaSchultze

    Joined:
    Feb 12, 2014
    Posts:
    256
    There's an option in the preferences called
    Do Not Use wmctrl
    , try disabling it. It was implemented as a workaround for Ubuntu systems, it's probably the same issue you're experiencing. (This will have the side effect of disabling the ability to fullscreen the main view). Let me know if this improves the experience on your environment.

    As a last resort, you can enable the option above and manually add a rect by choosing the "custom rect" as the placement source.

    One of the main problems of Linux is the discrepancy of behavior on different distros. On KDE this plugin runs almost flawless :(.
     
  41. shredingskin

    shredingskin

    Joined:
    Nov 7, 2012
    Posts:
    242
    Hello, I'm having a problem with Fullscreen editor in game mode, my game locks the mouse at the beginning and while using fullscreen it doesn't seem to focus on the game window, I need to alt tab to get it working properly.
    I'm using Unity 2021.1.9 on windows 10.
    Thanks.
     
  42. MukaSchultze

    MukaSchultze

    Joined:
    Feb 12, 2014
    Posts:
    256
    Hi,

    A very similar bug has been addressed in version 2.2.3, please make sure you've downloaded the latest version of the plugin.
    There's a bug in Unity's package manager that makes it download older versions on certain occasions. You can check the installed version in the plugin preferences, as shown below:

    upload_2021-5-28_23-43-11.png

    Let me know if that's not the case and if you're using the latest version of the plugin.

    Thanks for the feedback!
     
  43. shredingskin

    shredingskin

    Joined:
    Nov 7, 2012
    Posts:
    242
    I think it's the latest one since I bought it in the bundle well after 20/03.
    I can't tell you exactly the version because when I open the preferences it throws this error:
    Capture.JPG
    Weirdly enough now it seems to work as expected.

    The error it throws says:
    Code (CSharp):
    1. MissingMethodException: UnityEditor.EditorGUILayout.LinkLabel Due to: Attempted to access a missing member.
    2. FullscreenEditor.ReflectionUtility.FindMethod (System.Type type, System.String methodName, System.Type[] args, System.Boolean throwNotFound) (at Assets/Fullscreen/Editor/ReflectionUtility.cs:96)
    3. FullscreenEditor.ReflectionUtility.FindMethod (System.Type type, System.String methodName, System.Type[] args, System.Boolean throwNotFound) (at Assets/Fullscreen/Editor/ReflectionUtility.cs:86)
    4. FullscreenEditor.ReflectionUtility.InvokeMethod[T] (System.Type type, System.String methodName, System.Object[] args) (at Assets/Fullscreen/Editor/ReflectionUtility.cs:124)
    5. FullscreenEditor.FullscreenPreferences+<>c.<OnFooterGUI>b__30_0 (UnityEngine.GUIContent label) (at Assets/Fullscreen/Editor/FullscreenPreferences.cs:254)
    6. FullscreenEditor.FullscreenPreferences.OnFooterGUI () (at Assets/Fullscreen/Editor/FullscreenPreferences.cs:258)
    7. UnityEditor.SettingsProvider.OnFooterBarGUI () (at <4cbd678da9d34d10b88d29af4998c9e0>:0)
    8. UnityEditor.SettingsWindow.DrawFooterBar () (at <4cbd678da9d34d10b88d29af4998c9e0>:0)
    9. UnityEditor.SettingsWindow.DrawSettingsPanel () (at <4cbd678da9d34d10b88d29af4998c9e0>:0)
    10. UnityEngine.UIElements.IMGUIContainer.DoOnGUI (UnityEngine.Event evt, UnityEngine.Matrix4x4 parentTransform, UnityEngine.Rect clippingRect, System.Boolean isComputingLayout, UnityEngine.Rect layoutSize, System.Action onGUIHandler, System.Boolean canAffectFocus) (at <b3253b03938044f49f49c12d2de4cd71>:0)
    11. UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr, Boolean&)
     
  44. MukaSchultze

    MukaSchultze

    Joined:
    Feb 12, 2014
    Posts:
    256
    I tried to reproduce this bug on my machine but no success. Let me know if you come across this issue again.

    About the error on the preferences page, that has been fixed and will be shipped soon.
     
  45. Lordmin

    Lordmin

    Joined:
    Mar 9, 2017
    Posts:
    62
    From the Preferences > Fullscreen Edit > Shortcuts menu

    1. Is it possible to change the Game View key to 'ESC' Key?

    2. Is there any other way to exit the Game View state with the 'ESC' key?
     
  46. MukaSchultze

    MukaSchultze

    Joined:
    Feb 12, 2014
    Posts:
    256
    ESC is not a valid shortcut in Unity, this is a limitation of the Editor. Even built-in commands cannot be assigned to ESC.
     
  47. fordtimelord

    fordtimelord

    Joined:
    Nov 3, 2020
    Posts:
    21
    Are there any plans or at least wonky workarounds for multi-monitor macs? I’m bummed I can’t get it to work at all :(
     
  48. MukaSchultze

    MukaSchultze

    Joined:
    Feb 12, 2014
    Posts:
    256
    You can try setting a custom rect source in the preferences, it's the only way right now.

    There's a new set of APIs for dealing with multi-display setups in the latest version of Unity, I might be able to use them to improve mac support in the future.
     
    fordtimelord likes this.
  49. JohnnyFactor

    JohnnyFactor

    Joined:
    May 18, 2018
    Posts:
    343
    Possible bug report.

    Fullscreen asset normally works well, until the Unity session runs long or I've been flipping through a lot of different windows. At some point, the Game window drops from 60fps to 30fps or even lower. "Maximize on Play" stills runs at 60fps but switching to fullscreen immediately drops it back down. Restarting Unity fixes the issue, but it eventually comes back.

    - Unity 2020.3.x
    - DX11 mode
    - Windows 10
    - 4k monitor
    - 2nd 1080p monitor (not used for fullscreen)
     
  50. MukaSchultze

    MukaSchultze

    Joined:
    Feb 12, 2014
    Posts:
    256
    I'll take a look, do you have some idea of how long it takes for this bug to be noticeable?