Search Unity

  1. The 2022.1 beta is now available for testing. To find out what's new, have a look at our 2022.1 beta blog post.
    Dismiss Notice

[RELEASED] Emerald AI 3.0 (New HUGE Update) - The Ultimate Universal AAA Quality AI Solution

Discussion in 'Assets and Asset Store' started by BHS, Jun 26, 2015.

?

Which main feature would you like to see in the upcoming 2.6 Emerald AI update?

  1. Strafing - Allow AI to strafe in circles around their targets within a customizable distance.

    22.8%
  2. Stats - Allow AI to have additional stats, such as stamina and mana, usable by an AI's abilities.

    22.8%
  3. Sound Detection - Allow AI to detect sounds within a certain distance of their position.

    54.3%
  1. Deckard_89

    Deckard_89

    Joined:
    Feb 4, 2016
    Posts:
    307
    @wood333 Try this:
    On the AI's "On Take Damage Event", Call 2 methods on the AI:
    In "Emerald AI Events Manager": SetCombatTarget
    In "Emerald AI Detection": SetDetectedTarget

    Both fields should have your Invector player collider assigned (I have never used Invector Controller so I'm not sure specifically what that should be, probably just the same game object as the player itself). This should tell the AI to attack your player when it is damaged.
     
  2. wood333

    wood333

    Joined:
    May 9, 2015
    Posts:
    787
    Kind of overkill, but if the On Take Damage Event fires, then that should do it. I hook up lots assets with unity events. Good suggestion, thank you. I also learned that for the integration to do damage I must use the enemy tag/layer on the ai. the new docs show a setup with Emerald AI and AI, but for integration damage, it needs to be enemy enemy. Whatever works I will go with.
     
  3. RazT

    RazT

    Joined:
    Feb 7, 2019
    Posts:
    13

    BUMP!!! + additional :

    The "obstruction Igonore Layers" description is confusing me... Emerald AI 2.0 has ....you can set the "layermask to nothing" where Emerald AI 3.0 has "layermask to nothing". I just want to use shield in a way that the AI avoids it. WHAT needs to be done on the collider sphere on the Layer shield.?
     

    Attached Files:

  4. wraith1821

    wraith1821

    Joined:
    Nov 26, 2017
    Posts:
    30
    Awesome! Ill keep an eye out for it :)
     
  5. SickaGamer

    SickaGamer

    Joined:
    Jan 15, 2018
    Posts:
    1,165
    Sweet! Good job Will! Hopefully the updates keeping coming out like this one! Do you have a list of features for 3.1?
     
  6. micuccio

    micuccio

    Joined:
    Jan 26, 2014
    Posts:
    137
    Hi there!
    Does anyone know how to spawn particles with an event on the animations? like the footstep sounds.
    I would like to spawn throw events some dust particles on the AI feet.

    Thanks in advance,

    Dom
     
  7. Mad_Mark

    Mad_Mark

    Joined:
    Oct 30, 2014
    Posts:
    471
    Just a suggestion, rather than using events to generate another call, why not take advantage of what is already being called by Emerald? Emerald includes the PlayStepSound function in CharacterHelper.cs. Why not just add a particle system and add code to that function?

    If you just want to play a dust poof every time a footstep sound plays regardless of the surface type, add this one line at the end of the function:
    DustPuff();

    Then add a new function outside of the PlayStepSound function:
    Code (CSharp):
    1.  
    2. void DustPuff()
    3. {
    4.      GameObject puff = Instantiate(<your particle system>, position, Quaternion.identity);
    5.      puff.GetComponent<ParticleSystem>().Play();
    6. }
    This is untested code, but it should work I think.

    If you REALLY want to call another function with events, check YouTube. Plenty of tutorials there.
    Here is a basic one, but you should do a search there for more.


    Good luck!
     
  8. micuccio

    micuccio

    Joined:
    Jan 26, 2014
    Posts:
    137
    Hey, Thank you!
    I will check it now!
    Again thank you!
     
  9. micuccio

    micuccio

    Joined:
    Jan 26, 2014
    Posts:
    137
    Another thing if I may.
    I still have some issues concerning the AI approaching the Player and passing from Run to Walk.
    It is possible to shorten the final walking part? I would like to have the AI reaching the player in full run and maybe the last steps in Walk. In this way will look more aggressive.

    Thank you again,

    Dom
     
  10. MonstaManly

    MonstaManly

    Joined:
    Apr 18, 2020
    Posts:
    7
    Hey, I'm having a issue where my ai no does hit animations now that I enabled LBD. I am also using opsive UCC with the integration, my AI does cause damage correctly it just doesn't cause the effect like it used to pre LBD
     
  11. aradhyesoham

    aradhyesoham

    Joined:
    Dec 18, 2020
    Posts:
    1
    I am currently facing a bug where the AI enemy is not targeting the player even after adding the Target Position Modifier Script. Please help.
     

    Attached Files:

  12. BHS

    BHS

    Joined:
    Dec 21, 2009
    Posts:
    4,521
    If you want the layer ignored, you add the layer to the Obstruction Ignore Layers. For clarification, this feature is only for ignoring a collider that may be obstructing an AI's line of sight.
     
  13. BHS

    BHS

    Joined:
    Dec 21, 2009
    Posts:
    4,521
    Thanks! I will be posting the release notes soon. The 3.1 update should be live today. This update's main purpose is improving root motion movement, improving the folder structure, and adding new demo scenes, as well as some important bug fixes.
     
  14. BHS

    BHS

    Joined:
    Dec 21, 2009
    Posts:
    4,521
    The 3.1 update will add the ability to control the distance that forces an AI to walk before approaching their target. It even has the option to set it to 0 to remove the feature entirely.
     
  15. BHS

    BHS

    Joined:
    Dec 21, 2009
    Posts:
    4,521
    Things to check as it sounds like your AI is detecting your player as an AI:
     
  16. micuccio

    micuccio

    Joined:
    Jan 26, 2014
    Posts:
    137
    Thank you! looking forward to it :)
     
  17. BHS

    BHS

    Joined:
    Dec 21, 2009
    Posts:
    4,521
    Hey everyone,

    Emerald AI 3.1.0 is now live. This update includes some important bug fixes as well as some much needed improvements to how Emerald AI's Root Motion is calculated. This update also brings new demo models and demo scenes to help better showcase Emerald AI's functionality and capabilities.

    Please read the following before updating as Emerald AI's folder structure is making some changes with this update. This allows users to bypass including the demo sources and scene as well as having demo source objects be much more organized.

    Important

    First of all, it is highly recommended that users backup their projects before updating. This update improves the folder structure of Emerald AI, has new demo scenes and demo objects, and improvements to Root Motion movement.
    It is important that users regenerate their AI's Animator Controllers after importing the update.

    This update also brings improvements to the Animator Controller so users will need to regenerate them to have improved animation transitions. This can be done by pressing the Regenerate button within the Animation tab of the Emerald AI Editor.

    For users who do not care about removing the previous Emerald AI assets (or who can't), you can import the 3.1 update without any issues. This will just mean that users will have both demo sources.

    (For users who want to remove the previous demo objects)
    If users feel comfortable, and have backed up their projects, they should be able to remove everything within the Emerald AI folder (Not the Emerald AI folder itself) to avoid having the previous demo objects take up unneeded space. Be aware of any files you have created within the Emerald AI folder and to not delete them. If you have custom faction data, ensure you backup your Faction Data asset before updating or removing the previous version. After all this has been done, users can import version 3.1 of Emerald AI. Once again, use caution while doing this and only do this if you do not want the previous demo objects in your project, and that you have a backup of your project.

    3.1.0 Release Notes
    Changes to Emerald AI's folder Structure
    • Removed all previous demo scenes and files and replaced them with new Emerald AI demos and new models with root motion animations to better showcase Emerald AI's features and capabilities.
    • Completely restructured all demo files so they no longer have to be imported and so the folder structure is cleaner. While it's highly recommended users include the demo files and scenes, these can now be excluding when initially importing Emerald AI.
    • Some previous unused scripts were removed.
    Improvements
    • New Demos and demo models to better show Emerald AI's features and capabilities.
    • Big improvements to how Emerald AI's Root Motion is calculated which allows for much smoother transitions, more fluid movement, and stopping quicker. This is showcased in the new Emerald AI demos.
    • Allowed the WalkFootstepSound and RunFootstepSound to play when called from stationary turn animations so footstep sounds could be played while turning.
    • Added Force Walk Distance to the Emerald AI Editor (located under AI's Settings>Combat>Damage Settings) that allows users control the distance in which an AI will start walking instead of running as it approaches its target. This setting can also be set to 0 if users would like this feature disabled.
    • Added new AI prefabs to help get users get started quicker.
    Fixes
    • Fixed a bug that allowed AI using Line of Sight to sometimes detect targets through the floors and walls both on the first time detecting a target and after kill one.
    • Fixed various bugs related to companion AI.
    • Fixed a bug that caused some EmeraldAIProjectiles script to not properly set the added sphere collider to (0,0,0) which resulted in incorrect projectile collisions.
    • Fixed a bug that caused foot sliding when using run animations.
    • Fixed a bug that could allow some AI to get stuck in a loop of their turning left and turning right animations.
    • Fixed a bug that sometimes allowed an AI to skip its second waypoint when using the Loop or Reverse Waypoint Types.
    • Fixed a bug that didn't allow an AI's Stopping Distance to be set to its Attack Distance when getting a target while in the process of reversing its waypoints.
    • Fixed a few warning messages from some of Emerald AI's scripts.
    • Stopped allowing warning messages to be displayed for setting up a faction and melee attacks/ranged abilities when using a non-combat Passive AI.
    • Added a check to ensure the file path of an Animator Controller exists before regenerating an Animator Controller (When pressing the Regenerate Animator Controller button). This previously lead to a lost reference to the AI's Animator Controller. Instead, this notifies users to just clear the Animator Controller and create a new one which will fix the missing reference and update the Animator Controller.
     
    Last edited: Nov 4, 2021
  18. Eyehawk

    Eyehawk

    Joined:
    Dec 24, 2012
    Posts:
    280
    Hi there,
    I have a problem with Ranged AI not being able to attack the player if it has lined of sight.

    I have a couple of examples below. The AI seems to be unable to attack across unwalkable areas, even if they are:
    • Lower than the AI's head transform position
    • The layer of the obstacle is set to "Ignore Raycast"
    • The AI is set to "Stay Stationary"
    The AI will walk to a spot where it has line of sight from within the navmesh itself.





    However, if there is no path to the player from the Navmesh, it will be able to attack the player:

    I'm currently using Emerald v2 (still waiting for v3 to become available).
    Is there a way to make the AI shoot over low (navmesh unwalkable) obstacles?
     
  19. Hewhoisseth

    Hewhoisseth

    Joined:
    Aug 9, 2013
    Posts:
    2
    Hello BHS, I used Emerald about 6 months ago and realized there was no flinch animations being triggered when an AI was moving, so if a zombie is running at the player, and being shot by pistol, it appears to have no effect on the zombie (no flinch) and then it dies if shot enough. You responded 6 months ago that it was something that wasn't implemented yet but would be in the future. My hope is that it is now working? I want to buy the new version but not until I know if that is working.
     
  20. Eyehawk

    Eyehawk

    Joined:
    Dec 24, 2012
    Posts:
    280
    It turns out that upgrading to v3 fixed the issue! Glad I picked up :)
     
    julianr likes this.
  21. Fraka

    Fraka

    Joined:
    Oct 7, 2019
    Posts:
    2
    Hello, I have just purchased Emerald AI. I have a problem when using root motion the AI never run. Whether in combat or not. Even with the movement animation "Run". It only walk. Did I miss something ?
    If I use the nav mesh driven without touching anything else it work and the AI run.
     
  22. AaronVictoria

    AaronVictoria

    Joined:
    Aug 21, 2010
    Posts:
    165
    @BHS just something I thought I'd post here. The LocationBasedDamage script assumes that just because I'm using a hitbox style damage system that I also want to deaths to use the ragdoll functionality; setting the ragdoll death type for me on initialization. I've hacked in an external fix for that, but might be something to consider in the future. I'm using a character that is just far too large for reasonable looking ragdolling, so I was forced to use collision regions with animated deaths. This gave the project's animators far more control over the look of the toppling giant.
     
  23. ThorongBleidd

    ThorongBleidd

    Joined:
    Apr 13, 2020
    Posts:
    1
    @Fraka , I have the same problem. A quick (temporary) fix is to go to the "MoveAIRootMotion()" method in "EmeraldAISystem.cs" and change the behavior when in MovementState.Run (the last if/else statement in the method):

    Code (CSharp):
    1.  
    2. if (CurrentMovementState == MovementState.Run)
    3.                             {
    4.                                 /*if (AIAnimator.GetFloat("Speed") > 0.1f)
    5.                                     AIAnimator.SetFloat("Speed", 1f, 0.4f, Time.deltaTime);
    6.                                 else
    7.                                     AIAnimator.SetFloat("Speed", 0.1f, 0.4f, Time.deltaTime);*/
    8.                                 AIAnimator.SetFloat("Speed", 1f, 0.4f, Time.deltaTime);
    9.                             }
    10.  
    (The commented if/else is the original code. The last line fixes the issue.)

    Why does this happen? "Speed" is usually set as 0.1f when walking. So even when it is set to running, it won't go to 1f because the if-statement isn't true.

    @BHS I guess that's a bug? A missing >= maybe? And is there a reason why run should ever be set to 0.1f?
    In addition I'm not a fan of these magic strings, and would prefer that all animator parameters would be called using their ID :)
     
    BertTheNerd and Fraka like this.
  24. sebasfreelance

    sebasfreelance

    Joined:
    Aug 27, 2015
    Posts:
    229
    Hi,

    I have a problem with version 3.1, on the other hand with version 2.5 it does not happen to me.

    In version 3.1, the enemy does not shoot the player from a distance, only if the player is colliding with the enemy, I have tried the same prefab with 3.1 and 2.5, and I don't know why the distance shooting does not work in 3.1 , on the other hand in 2.5 it does it well.

    Any idea why this happens to me?

    Another problem is that when I use the ik, the head turns 90º to the right, I have everything well configured according to the tutorial.

    Thank you
     

    Attached Files:

    • cap.jpg
      cap.jpg
      File size:
      798.4 KB
      Views:
      32
  25. Fraka

    Fraka

    Joined:
    Oct 7, 2019
    Posts:
    2
    Thank you very much, that's exactly what I needed
     
  26. Blackghost

    Blackghost

    Joined:
    Oct 2, 2012
    Posts:
    104
    Does the new updated version of Emerald AI work with the updated version of Invector?
     
  27. SickaGamer

    SickaGamer

    Joined:
    Jan 15, 2018
    Posts:
    1,165
    @BHS
     
  28. BeorGames

    BeorGames

    Joined:
    Jul 28, 2018
    Posts:
    37
    Hello, I couldn't find it on the pages,but how do I upgrade the materials inside the package to use URP? I'm trying to learn how to use it with the Demo scenes, but it's all pink and I can't understand what's happening.

    Also, if someone can indicate me some video tutorials for creating an enemy AI using it I'd appreciate.
     
  29. beowulfkaine

    beowulfkaine

    Joined:
    Apr 3, 2014
    Posts:
    182
    Can this be integrated with a Virtual sword used by a VR player? What modifications if any would I have to do to make a physical sword interact with the ai and take damage and ragdoll on death?

    Does anyone know how to use the example scripts, there's no documentation on it. Specifically, DamageAIByCollision.cs
     
    Last edited: Nov 21, 2021
  30. BertTheNerd

    BertTheNerd

    Joined:
    Jun 5, 2017
    Posts:
    13
    Hi there, is there any update on this? One can setup hit animations also for Combat (Walking) but nothing is triggered. I use the lastest version and checked that with Damage AI Example. The moment an AI starts to move no hit animation is played. When the AI is idle it plays hit animations. Such a feature is crucial for shooter style things. thank you very much
     
  31. f8f82009

    f8f82009

    Joined:
    Nov 29, 2020
    Posts:
    4
    How do I increase the attack speed of the enemy?

    How do I increase the size of the enemy radar sensor to monitor the player?
     
  32. jasonxtate66

    jasonxtate66

    Joined:
    Nov 21, 2017
    Posts:
    133
    If we already have 2.0, is there a discount to upgrade?
     
  33. BertTheNerd

    BertTheNerd

    Joined:
    Jun 5, 2017
    Posts:
    13
    Does somebody use Emerals AI with root motion? I have a zombi with root motion which should run to the player and attack it. It just slowly walks to the player and the anim is not changed which seems to be ok because the created Animator works on speed (Nav mesh driven). the same AI with nav mesh movement runs towards the player. I do not find anything in the docs. But I would assume that this is absolutely basic and that there are many people using Emerald AI with root motioned animation. I also tried Ellen of the Emerald Demo. When changing her so that she gets damage by the player she is also not running to the player to attack. Please help, Any hint is higly appreciated
     
  34. shadowjohnr

    shadowjohnr

    Joined:
    Feb 21, 2018
    Posts:
    3
    I am having an issue with 3.0.
    I just wanted to make the AI robot in the demos be able to switch between melee and ranged. I changed the melee one's attack type to "both" and went through literally every menu side-by-side to ensure all the ranged features are in as well.

    Whenever I hit play, the weapon type is swapped to range (I think this might have been just a simple "I'm swapping to ranged thing"), he plays the melee attack animation but fires the ranged bullet. Also once I do get within melee range of the robot, he just ceases to do anything for forever.
    Photo for me having the melee under melee and ranged under ranged:
    https://imgur.com/a/OoWDG5q


    I'm not sure what's wrong, but this happens no matter what I do. Fresh projects, fresh imports, it happens every time I have "both" selected.
     
  35. cloudkafu

    cloudkafu

    Joined:
    Mar 7, 2021
    Posts:
    3
    Hi,

    I've also encountered the problem that the AI is not running when using root motion. The problem place is the same as ThorongBleidd pointed out:

    Code (CSharp):
    1.                             if (CurrentMovementState == MovementState.Run)
    2.                             {
    3.                                 //Debug.Log("Current movement state is run, speed is " + AIAnimator.GetFloat("Speed"));
    4.                                 if (AIAnimator.GetFloat("Speed") > 0.1f)
    5.                                     AIAnimator.SetFloat("Speed", 1f, 0.4f, Time.deltaTime);
    6.                                 else
    7.                                     AIAnimator.SetFloat("Speed", 0.1f, 0.4f, Time.deltaTime);
    8.                             }
    Note that I just added a debug out there print out the current speed. Turned out that, when the state is run, the speed will stuck at around 0.0999997 and never increase past that threshold, so the true branch for the if statement is never run. Maybe some accuracy problem with Unity when you use the SetFloat with damper..

    Anyway, a quick fix would be just changing the line to if (AIAnimator.GetFloat("Speed") > 0.09f)
     
    BertTheNerd likes this.
  36. Keppu

    Keppu

    Joined:
    Mar 22, 2014
    Posts:
    1
    Am I missing some Example Scenes from the 3.0? The Wiki says there should be Example Scenes like: Companion Example, Raycast Hit AI, Tamable AI Example, Territorial AI Example, but this seems to be all I got.

    upload_2021-11-25_18-47-17.png

    Also, do you have a Discord server? Would be so much better to read stuff there instead of from this single thread.
     

    Attached Files:

  37. BertTheNerd

    BertTheNerd

    Joined:
    Jun 5, 2017
    Posts:
    13
    thank you so much!!
     
  38. BertTheNerd

    BertTheNerd

    Joined:
    Jun 5, 2017
    Posts:
    13
    Hello,
    when an AI is passive and injured by the player it starts to attack the player --> the animations are played but no damage is done.

    When debgging I find that in the case of "Agressive" the PlayerDamageComponent is set in EmeraldAISystem. In the case when the AI changes from passive to agressive and the player is attacked the PlayerDamageComponent is not set. Therefore the code in method SendEmeraldDamage() in EmeraldAISystem is not executed:
    if (PlayerDamageComponent != null)
    {
    PlayerDamageComponent.SendPlayerDamage(CurrentDamageAmount, this.transform, GetComponent<EmeraldAISystem>(), CriticalHit);
    }

    Does anybody know where this can be fixed? thanks
     
  39. mroshaw

    mroshaw

    Joined:
    Oct 11, 2020
    Posts:
    5
    Hello! I bought Emerald AI 3, mainly for animal /creature AI, and have a few problems:

    1.My AI walk through walls and buildings, also doing so when attacking the player. I have rigid bodies, colliders and valid NavMesh, I've configured layers, all sorts. Nothing I do can stop creatures pursuing players through walls and closed doors.

    2. No matter what I try, I can't stop my A is wandering in to my Gaia Water. I've used NavMeshVolume to correct the NavMesh, set the NavMeshAgents for the AI to walkable, set the Water layer as an avoidance layer in Emerald. I've configured and tweaked every layer properly I can find, but still the AIs wander off into the sea.

    3. No matter what timing settings I configure, as long as the player keeps moving, my AI won't attack. Only if the player stands still will an attack be initiated. This means there's no risk of death if the player simply keeps moving, even if very slowly.

    Any help would be greatly appreciated,
     
  40. ex626

    ex626

    Joined:
    Mar 31, 2021
    Posts:
    1
    hey guys im using emerald ai for VR dev and my ranged ai's fireball keeps attacking the floor of my player. anyidea why this is happening?
     
  41. cloudkafu

    cloudkafu

    Joined:
    Mar 7, 2021
    Posts:
    3
    Hi, I'd like to report a bug and a workaround for it.

    The bug is that when the player attack a ranged out-of-combat AI outside of her detection distance (with a range weapon, for example), the AI will notice the player and enter combat state, then she runs towards the player, but she will not start attacking when reached attack distance. She only stands there. She won't attack even when the player run much closer towards her.

    It seems that this happens when you have the AI's Look at type set to "Emerald IK".

    The problem is that the AI never sets the player as a detected target in this case, as a result it won't start the Body IK process. Later in the AttackState() function, the code checks BodyWeight and will cancel the attack if BodyWeight stays at 0, which will be the case for this bug.

    The workaround is to add SetDetectedTarget() call when AI is attacked but doesn't have current target. See the patch below.


    diff --git a/Assets/Emerald AI/Scripts/System/EmeraldAISystem.cs b/Assets/Emerald AI/Scripts/System/EmeraldAISystem.cs
    index b187fbe4..2a4ad7c9 100644
    --- a/Assets/Emerald AI/Scripts/System/EmeraldAISystem.cs
    +++ b/Assets/Emerald AI/Scripts/System/EmeraldAISystem.cs
    @@ -2295,6 +2295,7 @@ namespace EmeraldAI
    {
    DeathDelayActive = false;
    CurrentTarget = AttackerTransform;
    + EmeraldDetectionComponent.SetDetectedTarget(AttackerTransform);
    m_NavMeshAgent.destination = CurrentTarget.position;
    m_NavMeshAgent.stoppingDistance = AttackDistance;
     
  42. wlabsocks

    wlabsocks

    Joined:
    May 21, 2020
    Posts:
    1
    if you can A* PathFinding/Emerald AI 3.0 Integration its would be great! ;)
     
  43. mayhemstudios

    mayhemstudios

    Joined:
    May 4, 2019
    Posts:
    1
  44. wood333

    wood333

    Joined:
    May 9, 2015
    Posts:
    787
    On my first attempt at AI "Look At", I was able to get it working, but the AI looks down at the Player's feet. How is this remedied? The AI is set for Unity IK, AI is humanoid, and otherwise is wandering and looking pretty good.
     
  45. f8f82009

    f8f82009

    Joined:
    Nov 29, 2020
    Posts:
    4
    BertTheNerd likes this.
  46. wood333

    wood333

    Joined:
    May 9, 2015
    Posts:
    787
    Bravo! Good!
     
  47. Grzegorz_Kwasniewski

    Grzegorz_Kwasniewski

    Joined:
    Feb 4, 2016
    Posts:
    4
  48. gtox

    gtox

    Joined:
    Apr 23, 2013
    Posts:
    22
    I have an issue with my animals where they don't seem to spend any time in an idle state - they walk a few meters, turn, walk a few meters, turn, and repeat for quite a while before moving off and walking in a straight line for some distance. They are using dynamic wandering, they have idle animations set up, and the minimum and maximum wait times are 30 and 60 seconds. I don't see any setting for idle behaviour All my animals behave like this (I have around 20 species) - when I see them they are either walking, running or walking in circles. I haven't updated to version 3 yet, as it would be quite a bit of work to get my animals redone, so I'd rather fix this in the version I'm using.
    Edit : My player had a sphere trigger collider, along with it's capsule collider, and this was causing the disruption to the AI behaviour. Removing the sphere collider fixed it.
     
    Last edited: Dec 19, 2021
  49. Chuy

    Chuy

    Joined:
    Mar 30, 2013
    Posts:
    1
    hi, someone knows if there is a way to use multiple colliders instead of a big one for damage an AI?, i have a dinosaur model with emerald implemented, it works but the default collider allows to damage the AI when hitting "empty areas" like between the legs or dosen't cover body parts like head or tail, i tried adding colliders to the main bones and a script that detect the hit and send the damage to the emerlad system but at start the emerlad system disables the new colliders and reenables the default one, i read in the wiki that there is a Location Based Damage implementation but that requires ragdoll death and i preffer to use animation death (also the ragdoll wizard seems to not work properly with non humanoids rigs)
     
  50. wood333

    wood333

    Joined:
    May 9, 2015
    Posts:
    787
    I have an AI that suddenly stopped using its run animations. I have root motion set and proper run animations in the animation slots for both combat and non combat. The ai targets, then walks over to attack. This is a stag. Its run animation is bounding, so I am certain the ai is not slowly playing a run. It only walks. I tried refresh and regenerate. No change. Any ideas? Oh, and I tried changing the movement type from walk to run. It still will not play the run animation.

    What setting could prevent an Ai from ever running?

    note: I can force the run by manually adjusting the movement blend tree slider.
     
    Last edited: Dec 14, 2021
unityunity