Search Unity

Regression on Unity 2020.3.22f1 (iOS) with "Post Processing" unchecked

Discussion in 'iOS and tvOS' started by Knbmedia, Nov 11, 2021.

  1. Knbmedia

    Knbmedia

    Joined:
    Dec 8, 2014
    Posts:
    18
    Hi,

    I noticed a regression between Unity 2020.3.21f1 and Unity 2020.3.22f1 on iOS (Metal) with URP.
    I have now a sort of white borders instead of transparency on some of my 3D Objects (not on UI).
    This occurs only if the "Post Processing" checkbox on the main camera is unchecked.
    If I check the "Post Processing" button on my camera, these artifacts disappear!

    It's easy to reproduce:
    -> Create a new URP project.
    -> Create a material with a texture with alpha channel and apply to a cube.
    -> Uncheck "Post Processing" checkbox on the main camera.
    -> Build on iOS (works on Macos Editor).

    bug1.jpg bug2.jpg

    I tried to update first URP package from 10.6 to 10.7 before updating to 2020.3.22f1: it worked.
    So it's only after updating to 2020.3.22f1 that the problem occurs.

    PS: Not sure if it's the same problem but I noticed too that if I set the background camera color to black (instead of Skybox), the background appears WHITE on iOS if "Post processing" is unchecked...
     
  2. Knbmedia

    Knbmedia

    Joined:
    Dec 8, 2014
    Posts:
    18
    I've just reported the bug (case 1380005).
     
  3. SarperS

    SarperS

    Joined:
    Mar 10, 2009
    Posts:
    824
    Happens on built-in render pipeline as well, with no workarounds that I could find.
     
    rumorgames likes this.
  4. Knbmedia

    Knbmedia

    Joined:
    Dec 8, 2014
    Posts:
    18
  5. xyome

    xyome

    Joined:
    Jul 4, 2014
    Posts:
    9
    Can you please try to put your device in Dark Mode and see if it helps?
     
  6. Knbmedia

    Knbmedia

    Joined:
    Dec 8, 2014
    Posts:
    18
    @xyome : yes, I've just tested and in Dark Mode it works without problem!
     
  7. arom1989

    arom1989

    Joined:
    Jun 1, 2021
    Posts:
    5
    @SarperS We had the same problem on the builtin pipeline and we ended up using basic surface shaders to replace the fragment shaders that caused the problem.
     
  8. SarperS

    SarperS

    Joined:
    Mar 10, 2009
    Posts:
    824
    Thanks, I can't do that sadly, I use custom lighting in my shaders. Gonna stick with not updating Unity for iOS builds for now :/
     
  9. ulrikdamm

    ulrikdamm

    Joined:
    Jun 7, 2016
    Posts:
    1
    Until this gets fixed, you can force your app to always be in dark mode by adding
    <key>UIUserInterfaceStyle</key><string>Dark</string>

    to the info.plist file in Xcode (or with a build script).