Search Unity

[Regression] In linear Space, Game scene & editor are way more dark from 2017.4 LTS to Unity 2018.2b

Discussion in 'General Graphics' started by Whatever560, Apr 27, 2018.

  1. Whatever560

    Whatever560

    Joined:
    Jan 5, 2016
    Posts:
    111
    [Update]
    We narrowed the issue as when switching from gamma to linear space everyhting from Game view, scene view and editor view gets darker

    [First question]
    Pictures are better than words, here are comparison screenshot of two new scenes, in 2017 and 2018 versions. Any help on this? Maybe some project files to regenerate or tweak ?

    Unity 2018.x ( 2018.1RC, 2018.2.0b2)
    upload_2018-4-27_12-13-9.png

    Former unity versions :
    upload_2018-4-27_12-14-21.png
     
    Last edited: Apr 27, 2018
  2. Whatever560

    Whatever560

    Joined:
    Jan 5, 2016
    Posts:
    111
    Our test so far :
    - When switching to linear space everything goes broken again
    - When switching back to Gamma space, everything comes back to normal.

    This behaviour can't be observed with a brand new project.
    In our setup, we can go back and forth between linear and gamma and bug is always occurring.

    Don't ask for a repro as we have none idea on why this is happening ...
     
    Last edited: Apr 27, 2018
  3. Whatever560

    Whatever560

    Joined:
    Jan 5, 2016
    Posts:
    111
    We tried changing the windows graphical APIs but nothing changed in linear space (DX12, openGLx)
     
  4. MaxSamarin

    MaxSamarin

    Joined:
    Nov 11, 2016
    Posts:
    3
    I have the exact same issue. Only happens in Linear, and in a specific project that I moved from 2017.3. Editor gets darker in Linear as well. I also moved another empty project from 2017.3 to 2018.1 and that one does not have the issue.
     
  5. romaing

    romaing

    Joined:
    Feb 11, 2010
    Posts:
    24
    Same here, I tried some workarounds, like creating a project from scratch then importing a package but still have the "everything gets darker" issue eventually:

    Capture d’écran 2018-05-04 à 11.20.46.png
     
  6. marctem

    marctem

    Unity Technologies

    Joined:
    Oct 31, 2016
    Posts:
    1
    MaxSamarin likes this.
  7. romaing

    romaing

    Joined:
    Feb 11, 2010
    Posts:
    24
  8. Whatever560

    Whatever560

    Joined:
    Jan 5, 2016
    Posts:
    111
    Issue is still happening for us from 2017.4 LTS to 2018.3.6f1. Preventing from updating. The linked issue seems totally unrelated as we do not enable collab. We tried :

    - Removing all project settings and let unity generate new one. Switching to Linear still makes the UI and webview dark.
    - Silence all our 3rd parties (as presented in the comments of the issuetracker linked to avoid incompatibilities)

    Moreover, the "Package Manager" entry does not show up in the "window" menu.

    These are few of the hurdles we have when trying to upgrade from 2017.4 to 2018.3
     
  9. mr_blahblah

    mr_blahblah

    Joined:
    Jan 15, 2016
    Posts:
    25
    Still getting this issue in 2018.3.11. For anyone concerned, comments on https://issuetracker.unity3d.com/is...a-collab-project-is-opened-for-the-first-time allege it fixable by deleting some internal gui shaders fixes the issue.

    Can confirm this works on a project upgraded from 5.6 to 2018.3.11 - neccessary for me so I can actually light scenes properly.


    Deleting Internal-GUITextureClip fixed dark editor

    Also:
    Deleting Internal-GUITextureBlit fixed dark game view
     
  10. Whatever560

    Whatever560

    Joined:
    Jan 5, 2016
    Posts:
    111
    Not Working for us
     
  11. judgementAlex

    judgementAlex

    Joined:
    Sep 9, 2013
    Posts:
    27
    Have this issue with OpenGLCore editor on Linux, but swapping to Vulkan fixes it. There are other issues with Vulkan though so not an ideal solution

    Should mention: only seems to be present using Intel GPU
     
    Last edited: May 21, 2019