Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

Bug Reflect Viewer's streaming loading is inconsistent and random

Discussion in 'Unity Reflect' started by ChangSoft, Mar 22, 2021.

  1. ChangSoft


    Mar 22, 2021

    I have a very heavy model of a highway road from civil engineering.
    It is a naviswork-exported model.

    Its size is very large and it has many parts.

    I noticed that when the viewer load the data , it show a transparent blue box proxy shape for the real model while streaming the data. And the problem is the streaming is not consistent in the performance and sometimes it is very slow to completely load the data, so that it seems that some parts of the data will not load forever.

    The streaming seems to stop but the model is not completely loaded. The blue boxes are still there and it is not streaming data any more.

    And, whenever I try to load this model, the viewer sometimes load almost all of the parts and sometimes doesn't load at all, and it is very random.

    I want to share this problematic data here, but I don't know how.

    Attached Files:

    Davkar688 and jromero_pre like this.
  2. chafik_unity


    Unity Technologies

    Jun 27, 2017
    Hi @ChangSoft,

    The streaming system was designed to open and navigate big models by limiting the number of visible objects to prevent framerate drop and out-of-memory crashes.

    This limit is set to 10000 on some versions of Reflect. So maybe the model is reaching the limit?
    Also, since streaming is relying on camera position, the visible objects can change between executions.

    However, the blue box that doesn't load is a known issue and we're working on it.
    Keep in mind that the streaming system is core to Reflect and that we're constantly working on improving it. Feedback like yours is very appreciated!
  3. jromero_pre


    Dec 9, 2022
    Hi @chanfik-unity
    I have the same error, when I open a file from local I get both red and blue boxes randomly and the program doesn't completely load all the elements, do you know if this has a solution in a more updated version?
    I attach images of what happens to me

    Attached Files:

    Last edited: Dec 14, 2022
  4. Jkshow


    Nov 17, 2022
    The same thing happens to me when I load an extremely large 1.3GB Revit file into Unity Reflect is there any workarounds to get this to be solved?