Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. We are updating our Terms of Service for all Unity subscription plans, effective October 13, 2022, to create a more streamlined, user-friendly set of terms. Please review them here: unity.com/legal/terms-of-service.
    Dismiss Notice
  3. Have a look at our Games Focus blog post series which will show what Unity is doing for all game developers – now, next year, and in the future.
    Dismiss Notice
  4. Join us on Thursday, September 29, for a day with Unity's SRP teams here on the forum or on Reddit, and discuss topics around URP, HDRP, and the Scriptable Render Pipeline in general.
    Dismiss Notice

Bug Reflect 2.0 - asset import failed importing revit model, material shaders are null

Discussion in 'Unity Reflect' started by VincentGoupil, Jan 12, 2021.

  1. VincentGoupil

    VincentGoupil

    Joined:
    Apr 1, 2019
    Posts:
    14
    Hi,

    When I import a model using the reflect window from a revit model, not one material is imported without failing.

    This error happens after uptading Reflect to 2.0 on a new Unity project. I tried to import the same Revit model in my first Unity Project in 2019.4.17 with Reflect 1.3 and no errors.

    So, maybe i miss something in the new project also in 2019.4.17. The project is literally empty, with only the Reflect package 2.0.

    I attached a screen of the error.

    And I tried to view the same model in the last Reflect Viewer and everything work fine.
     

    Attached Files:

  2. KamikazePlatypus

    KamikazePlatypus

    Joined:
    Jan 17, 2019
    Posts:
    3
    I am getting the same error.
     
  3. eproca_SimRTR

    eproca_SimRTR

    Joined:
    Nov 8, 2018
    Posts:
    16
unityunity