Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Official Recorder release announcements

Discussion in 'Audio & Video' started by markvi, Mar 9, 2021.

Thread Status:
Not open for further replies.
  1. markvi

    markvi

    Joined:
    Oct 31, 2016
    Posts:
    118
    This thread will be updated each time a new version of the Recorder package becomes available.

    For more information about the Recorder package, please have a look at our documentation.

    Please create a new thread for feature requests, bug reports, or general discussion using the recorder tag. For bug reports in particular, it helps us immensely if you prepare a minimal project that reproduces your issue. Submit a bug report using the Unity Bug Reporter and include the id you receive (via email) in your post.
     
    Last edited: Mar 30, 2021
  2. markvi

    markvi

    Joined:
    Oct 31, 2016
    Posts:
    118
    We are pleased to announce that Recorder version 2.6.0-exp.4 is now available.

    Changes from the previous version:
    • Fixed an invalid AOV error when selecting the Albedo AOV.
    (The full changelog is available here)

    To install this package, open the Package Manager, click the + at the top left and select Add package by name.... Enter com.unity.recorder as the name and and 2.6.0-exp.4 as the version and click Add.

    Alternatively, you may edit Packages/manifest.json and add "com.unity.recorder": "2.6.0-exp.4",to the list of dependencies, or edit the existing entry for Recorder to update the version.

    > How to report bugs <
     
    Last edited: Mar 9, 2021
  3. markvi

    markvi

    Joined:
    Oct 31, 2016
    Posts:
    118
    Happy St. Patrick's day! Before we quaffed our pints of Guinness, we managed to release Recorder version 2.5.5.

    Changes from the previous version:
    • Fixed an error that occurred when setting the build target to macOS standalone from the Editor in Windows
    (As always, the full changelog is available here)

    This package is available for Unity 2019 LTS, 2020 LTS, 2021.1 beta and 2021.1 alpha. It's a released package (not -exp or -pre) and so is visible in the Package Manager window: just select it and click Install. It will also become verified in upcoming patch releases of 2019 LTS and 2020 LTS.

    > How to report bugs <
     
    svfxanimationstudio likes this.
  4. markvi

    markvi

    Joined:
    Oct 31, 2016
    Posts:
    118
    Hi folks!

    We wanted to let you know of an important (though experimental) update to Recorder which you might want to try.

    What's New
    We have published Recorder 2.6.0-exp.4. This experimental version integrates the functionality previously found in the AOV Recorder and adds support for HDRP's multiframe rendering and accumulation feature. Multiframe rendering and accumulation are necessary for capturing high-quality motion blur and converging lighting effects that use path tracing.

    Minimum Requirements
    Unity 2020.2.4.f
    HDRP 10.3.1

    OR

    Unity 2021.1.0b12
    HDRP 11.0.0

    How to Install
    1. In Unity 2020 LTS and above, click the [+] button at the top left of the Package Manager, select Add Package by Name... and enter com.unity.recorder in the Name field and 2.6.0-exp.4 in the Version field OR
    2. In any version of Unity, edit Packages/manifest.json and add the following line to the top of the list of dependencies:
      "com.unity.recorder": "2.6.0-exp.4",
    You can find more information on how to use this feature here: https://docs.unity3d.com/Packages/c...al/RecorderMovie.html#accumulation-properties

    Thanks as always!

    > How to report bugs <
     
  5. markvi

    markvi

    Joined:
    Oct 31, 2016
    Posts:
    118
    Hi everyone!

    We're proud to announce a new prerelease of Recorder, version 3.0.0-pre.1!

    What's New
    Recorder 3.0 adds support for subframe accumulation. Subframe rendering and accumulation are for capturing high-quality motion blur and converging lighting effects that use path tracing. You can find more information on how to use this feature here.

    Recorder 3.0 also includes support for generating AOV passes. This functionality was previously available in the AOV Recorder. You should remove the former AOV Recorder package before installing this version, or you may encounter errors. Read more about AOV recording here.

    Note that AOV outputs and subframe sampling are only available on projects that are using the High Definition Render Pipeline (HDRP).

    Recorder 3.0 removes the legacy recorders: MP4, EXR, PNG, WEBM and GIF Animation. All of these formats except animated GIF are still supported through the Movie or Image recorders. If you absolutely must generate animated GIFs, we recommend that you generate an MP4 movie instead, and use one of the many command-line, graphical, or online tools available to convert it to GIF format.

    And of course, we fixed a bunch of bugs. You can find the full changelog here.

    Minimum Requirements
    Unity 2019.4
    HDRP 7.3.1
    (please note that subframe accumulation will not be available in this configuration)

    OR


    Unity 2020.2.4.f
    HDRP 10.3.1

    OR


    Unity 2021.1.0b12
    HDRP 11.0.0

    How to Install
    You can install this package through the Package Manager or via your project’s manifest.
    • In Unity 2021.1 and above, click the [+] button at the top left of the Package Manager, select Add Package by Name... and enter com.unity.recorder in the Name field and 3.0.0-pre.1 in the Version field.

      OR

    • In Unity 2020.3, click the [+] button at the top left of the Package Manager, select Add package from git URL... and enter com.unity.recorder@3.0.0-pre.1.

      OR

    • In any version of Unity, edit the “Packages/manifest.json” file and add the following line to the top of the list of dependencies:
      "com.unity.recorder": "3.0.0-pre.1",

    Thanks as always!

    > How to report bugs <
     
    Last edited: Apr 27, 2021
    svfxanimationstudio likes this.
  6. unitybru

    unitybru

    Unity Technologies

    Joined:
    Jan 28, 2020
    Posts:
    225
    Hi everyone!

    We're proud to announce a new prerelease of Recorder, version 3.0.0-pre.2!

    What's New
    Recorder 3.0.0-pre.2 adds support for Apple Silicon chips (arm64).
    It also fixes an issue of pixel stride for ProRes formats 4444 and 4444XQ that would only happen on macOS with certain combinations of aspect ratios and image height.
    Another bug fix is for audio recordings when the starting frame is different than zero.

    You can find the full changelog here.

    Minimum Requirements
    Unity 2019.4
    HDRP 7.3.1
    (please note that subframe accumulation will not be available in this configuration)

    OR


    Unity 2020.2.4.f
    HDRP 10.3.1

    OR


    Unity 2021.1.0b12
    HDRP 11.0.0

    How to Install
    You can install this package through the Package Manager or via your project’s manifest.
    • In Unity 2021.1 and above, click the [+] button at the top left of the Package Manager, select Add Package by Name... and enter com.unity.recorder in the Name field and 3.0.0-pre.2 in the Version field.

      OR

    • In Unity 2020.3, click the [+] button at the top left of the Package Manager, select Add package from git URL... and enter com.unity.recorder@3.0.0-pre.2.

      OR

    • In any version of Unity, edit the “Packages/manifest.json” file and add the following line to the top of the list of dependencies:
      "com.unity.recorder": "3.0.0-pre.2",

    Thanks as always!

    > How to report bugs <
     
    Lars-Steenhoff likes this.
  7. unitybru

    unitybru

    Unity Technologies

    Joined:
    Jan 28, 2020
    Posts:
    225
    Hi everyone!

    We're proud to announce a new prerelease of Recorder, version 3.0.0!

    What's New
    Recorder 3.0.0 fixes two bugs with regard to linear and sRGB conversions, addresses GameView resolution changes with multiple recorders in the samples, and avoids exceptions by detecting issues and logging error messages instead.

    You can find the full changelog here.

    Minimum Requirements
    Unity 2019.4
    HDRP 7.3.1
    (please note that subframe accumulation will not be available in this configuration)

    OR

    Unity 2020.2.4.f
    HDRP 10.3.1

    OR

    Unity 2021.1.0b12
    HDRP 11.0.0

    How to Install
    You can install this package through the Package Manager or via your project’s manifest.
    • In the Package Manager, find the Recorder (or "Unity Recorder") package, highlight version 3.0.0 and click the Install button.

      OR

    • In Unity 2021.1 and above, click the [+] button at the top left of the Package Manager, select Add Package by Name... and enter com.unity.recorder in the Name field and 3.0.0 in the Version field.

      OR

    • In Unity 2020.3, click the [+] button at the top left of the Package Manager, select Add package from git URL... and enter com.unity.recorder@3.0.0.

      OR

    • In any version of Unity, edit the “Packages/manifest.json” file and add the following line to the top of the list of dependencies:
      "com.unity.recorder": "3.0.0",

    Thanks as always!

    > How to report bugs <
     
  8. unitybru

    unitybru

    Unity Technologies

    Joined:
    Jan 28, 2020
    Posts:
    225
    Hi everyone!

    We're proud to announce a new prerelease of Recorder, version 3.0.1!

    What's New
    Recorder 3.0.1 fixes vertical flipping issues on the OpenGL graphic APIs, and performs linear to sRGB (and sRGB to linear) conversion when required, for the Texture Sampling recorder input (used for antialiasing).

    You can find the full changelog here.

    Minimum Requirements
    Unity 2019.4
    HDRP 7.3.1
    (please note that subframe accumulation will not be available in this configuration)

    OR

    Unity 2020.2.4.f
    HDRP 10.3.1

    OR

    Unity 2021.1.0b12
    HDRP 11.0.0

    How to Install
    You can install this package through the Package Manager or via your project’s manifest.
    • In the Package Manager, find the Recorder (or "Unity Recorder") package, highlight version 3.0.1 and click the Install button.

      OR

    • In Unity 2021.1 and above, click the [+] button at the top left of the Package Manager, select Add Package by Name... and enter com.unity.recorder in the Name field and 3.0.1 in the Version field.

      OR

    • In Unity 2020.3, click the [+] button at the top left of the Package Manager, select Add package from git URL... and enter com.unity.recorder@3.0.1.

      OR

    • In any version of Unity, edit the “Packages/manifest.json” file and add the following line to the top of the list of dependencies:
      "com.unity.recorder": "3.0.1",

    Thanks as always!

    > How to report bugs <
     
    cirocontinisio and Ubrano like this.
  9. unitybru

    unitybru

    Unity Technologies

    Joined:
    Jan 28, 2020
    Posts:
    225
    Hi everyone!

    We're proud to announce a new prerelease of Recorder, version 4.0.0-pre.1!

    What's New
    Recorder 4.0.0-pre.1 introduces a JPEG quality slider and a new wildcard for AOVs.
    This version also moves the troubleshooting options from the Editor menu to the User Preferences, exposes more classes to the public API (to facilitate your work writing custom Recorders with audio), changes the default output file names to avoid clashes, and makes it easier to show/hide/focus the Recorder Window (which you can attach to a keyboard shortcut as well).
    Finally, this version fixes the "open output location" functionality in Linux.

    You can find the full changelog here.

    Minimum Requirements
    Unity 2019.4
    HDRP 7.3.1
    (please note that subframe accumulation will not be available in this configuration)

    OR

    Unity 2020.2.4.f
    HDRP 10.3.1

    OR

    Unity 2021.1.0b12
    HDRP 11.0.0

    How to Install
    You can install this package through the Package Manager or via your project’s manifest.
    • In the Package Manager, find the Recorder (or "Unity Recorder") package, highlight version 4.0.0-pre.1 and click the Install button.

      OR

    • In Unity 2021.1 and above, click the [+] button at the top left of the Package Manager, select Add Package by Name... and enter com.unity.recorder in the Name field and 4.0.0-pre.1 in the Version field.

      OR

    • In Unity 2020.3, click the [+] button at the top left of the Package Manager, select Add package from git URL... and enter com.unity.recorder@4.0.0-pre.1.

      OR

    • In any version of Unity, edit the “Packages/manifest.json” file and add the following line to the top of the list of dependencies:
      "com.unity.recorder": "4.0.0-pre.1",

    Thanks as always!

    > How to report bugs <
     
    newguy123 likes this.
  10. unitybru

    unitybru

    Unity Technologies

    Joined:
    Jan 28, 2020
    Posts:
    225
    Hi everyone!

    We're proud to announce a new prerelease of Recorder, version 4.0.0-pre.2!

    What's New
    Recorder 4.0.0-pre.2 fixes many bugs and introduces support for variable frame rate for the H.264 and VP8 Recorders.
    This version also introduces a better handling of unsupported options in Linux.

    You can find the full changelog here.

    Minimum Requirements
    Unity 2019.4
    HDRP 7.3.1
    (please note that subframe accumulation will not be available in this configuration)

    OR

    Unity 2020.2.4.f
    HDRP 10.3.1

    OR

    Unity 2021.1.0b12
    HDRP 11.0.0

    How to Install
    You can install this package through the Package Manager or via your project’s manifest.
    • In the Package Manager, find the Recorder (or "Unity Recorder") package, highlight version 4.0.0-pre.2 and click the Install button.

      OR

    • In Unity 2021.1 and above, click the [+] button at the top left of the Package Manager, select Add Package by Name... and enter com.unity.recorder in the Name field and 4.0.0-pre.2 in the Version field.

      OR

    • In Unity 2020.3, click the [+] button at the top left of the Package Manager, select Add package from git URL... and enter com.unity.recorder@4.0.0-pre.2.

      OR

    • In any version of Unity, edit the “Packages/manifest.json” file and add the following line to the top of the list of dependencies:
      "com.unity.recorder": "4.0.0-pre.2",

    Thanks as always!

    > How to report bugs <
     
  11. unitybru

    unitybru

    Unity Technologies

    Joined:
    Jan 28, 2020
    Posts:
    225
    Hi everyone!

    We're proud to announce a new prerelease of Recorder, version 4.0.0-pre.3!

    What's New
    Recorder 4.0.0-pre.3 is only compatible with Unity versions 2022.1 and onwards.
    This release adds a new "Custom" quality for the Unity Media Encoder, so that you can have advanced encoding options for H.264 MP4 and VP8 WEBM.
    It also introduces an Encoding API for the Movie Recorder so that you can write your own video encoders.
    Some labels and options have moved around in the Recorder Window, for reasons of consistency and to distinguish between the capabilities of an encoder and a media source (e.g. support for audio and alpha).
    Your existing projects will be upgraded cleanly.

    You can find the full changelog here. (the updated changelog will appear after a little while)

    Minimum Requirements
    Unity 2022.1
    HDRP 12.0.0

    How to Install
    You can install this package through the Package Manager or via your project’s manifest.
    • In the Package Manager, find the Recorder (or "Unity Recorder") package, highlight version 4.0.0-pre.3 and click the Install button (you need to have enabled the option Enable Pre-release Packages in the Package Manager settings).

      OR

    • In Unity 2021.1 and above, click the [+] button at the top left of the Package Manager, select Add Package by Name... and enter com.unity.recorder in the Name field and 4.0.0-pre.3 in the Version field.

    • OR

    • In any version of Unity, edit the “Packages/manifest.json” file and add the following line to the top of the list of dependencies:
      "com.unity.recorder": "4.0.0-pre.3",

    Thanks as always!

    > How to report bugs <

    Encoding API example
    See the attached files for an example of a custom encoder. This implements a very useless export of PNG images (with no audio support), so it's not a real movie encoder, but it shows the pieces needed to create an encoder and see it in the Recorder Window. Passing the audio/video data to a native library is beyond the scope of this explanation, but a C# only encoder should be easy for any developer now.
    upload_2022-1-20_16-54-16.png

    upload_2022-1-20_16-54-24.png
     

    Attached Files:

    newguy123 and vladala like this.
  12. unitybru

    unitybru

    Unity Technologies

    Joined:
    Jan 28, 2020
    Posts:
    225
    Hi everyone!

    We're proud to announce a new release of Recorder, version 4.0.0-pre.4!

    What's New

    (Recorder 4.0.0-pre.4 is only compatible with Unity versions 2022.1 and onwards.)
    This release brings back GIF support, as one of the encoders available for Movie Recorders.
    It also includes shadow map filtering for spot lights, to significantly improve the quality of rendered shadows.
    A new option for subpixel jitter antialiasing is available for recorders with accumulation in HDRP projects. Additionally, movie recorders can now support audio when accumulation is enabled.
    The accumulation UX has been improved to help users make sense of the settings and prevent recordings when combining active recorders with and without accumulation.
    EXR image sequence recorders now support PIZ compression.
    ProRes encoding performance has been considerably improved. A side effect is that packed pixel formats (i.e., 422, 422 HQ, 422 Proxy, 422 LT) do not support odd resolutions anymore.
    When using custom encoding for VP8 and H.264, audio tracks now encode with the highest bitrate possible.
    Fixed an issue with the duration of recordings with time intervals in seconds.

    You can find the full changelog here.

    Minimum Requirements

    Unity 2022.1
    HDRP 12.0.0

    How to Install

    You can install this pre-release package through the Package Manager or via your project’s manifest.
    • In the Package Manager, find the Recorder (or "Unity Recorder") package, highlight version 4.0.0-pre.4 and click the Install button (you need to have enabled the option Enable Pre-release Packages in the Package Manager settings).
    OR
    • In Unity 2022.1 and above, click the [+] button at the top left of the Package Manager, select Add Package by Name... and enter com.unity.recorder in the Name field and 4.0.0-pre.4 in the Version field.
    OR
    • In any version of Unity, edit the “Packages/manifest.json” file and add the following line to the top of the list of dependencies: "com.unity.recorder": "4.0.0-pre.4"
    Thanks as always!
     
    Noisecrime, teutonicus and newguy123 like this.
  13. unitybru

    unitybru

    Unity Technologies

    Joined:
    Jan 28, 2020
    Posts:
    225
    Hi everyone!

    We're proud to announce a new release of Recorder, version 4.0.0-pre.5!

    What's New

    (Recorder 4.0.0-pre.5 is only compatible with Unity versions 2022.1 and onwards.)
    This version doesn't accumulate frames on skipped frames (e.g. you want to skip the first 30 frames; this is relevant for HDRP projects with accumulation).
    ProRes 4444 exports on Apple M1 Max CPUs have been fixed. Several other fixes have been made to the user experience with regards to accumulation, audio capture, timeline GIFs, and addressing conflictual recording contexts.
    This release also adds a new sample to show you how to integrate the Recorder package with command line encoders (e.g. FFmpeg).

    You can find the full changelog here.

    Minimum Requirements

    Unity 2022.1

    How to Install

    You can install this pre-release package through the Package Manager or via your project’s manifest.
    • In the Package Manager, find the Recorder (or "Unity Recorder") package, highlight version 4.0.0-pre.5 and click the Install button (you need to have enabled the option Enable Pre-release Packages in the Package Manager settings).
    OR
    • In Unity 2022.1 and above, click the [+] button at the top left of the Package Manager, select Add Package by Name... and enter com.unity.recorder in the Name field and 4.0.0-pre.5 in the Version field.
    OR
    • In any version of Unity, edit the “Packages/manifest.json” file and add the following line to the top of the list of dependencies: "com.unity.recorder": "4.0.0-pre.5"
    Thanks as always!
     
    Last edited: Jun 2, 2022
    newguy123 and vladala like this.
Thread Status:
Not open for further replies.