Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only. On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live. Read our full announcement for more information and let us know if you have any questions.

Realtime shadows on iOS with Unity4 Pro????

Discussion in 'iOS and tvOS' started by tigger, Jan 11, 2013.

  1. tigger

    tigger

    Joined:
    Jan 8, 2013
    Posts:
    95
  2. Alexey

    Alexey

    Unity Technologies

    Joined:
    May 10, 2010
    Posts:
    1,631
    did you enable shadows in quality settings for ios? That's the most usual reason ;-)
    Also, shadows need "GL_OES_depth_texture" gles ext. Honestly i dont remember at what ios version they added it, but later ones should have it (e.g. ipad2+ios5 does have it)
     
  3. derkoi

    derkoi

    Joined:
    Jul 3, 2012
    Posts:
    2,273
    Add a directional light, make sure in the inspector that shadows for the light are turned on, as by default they're not. You'll see shadows in the scene view (as long as you've got the little sun icon above the scene view window enabled)

    Then make sure the default quality has shadows enabled (by default i think it does)

    Build.

    If you still not getting shadows, change the shadow distance in the Quality settings to something higher.
     
  4. WHKS

    WHKS

    Joined:
    Dec 13, 2011
    Posts:
    61
    Ive done all this still no shadows
     
  5. nilupat77

    nilupat77

    Joined:
    Aug 17, 2017
    Posts:
    1
    use this settings its work in my project
     

    Attached Files: