Search Unity

  1. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

"Realtime GI is not supported in Universal Pipeline"

Discussion in 'Universal Render Pipeline' started by andrew210, Mar 13, 2020.

  1. andrew210

    andrew210

    Joined:
    Apr 23, 2014
    Posts:
    175
    Hello! Have switched to Universal Pipeline over the past few months, everything works great in editor however when running on device, adb reports this error message many times per frame:

    Code (CSharp):
    1. 03-13 19:55:19.222 31831 31878 W Unity   : Realtime GI is not supported in Universal Pipeline.
    2. 03-13 19:55:19.222 31831 31878 W Unity   : UnityEngine.DebugLogHandler:Internal_Log(LogType, LogOption, String, Object)
    3. 03-13 19:55:19.222 31831 31878 W Unity   : UnityEngine.DebugLogHandler:LogFormat(LogType, Object, String, Object[])
    4. 03-13 19:55:19.222 31831 31878 W Unity   : UnityEngine.Logger:Log(LogType, Object)
    5. 03-13 19:55:19.222 31831 31878 W Unity   : UnityEngine.Debug:LogWarning(Object)
    6. 03-13 19:55:19.222 31831 31878 W Unity   : UnityEngine.Rendering.Universal.<>c:<.cctor>b__40_0(Light[], NativeArray`1)
    7. 03-13 19:55:19.222 31831 31878 W Unity   : UnityEngine.Experimental.GlobalIllumination.RequestLightsDelegate:Invoke(Light[], NativeArray`1)
    8. 03-13 19:55:19.222 31831 31878 W Unity   : UnityEngine.Experimental.GlobalIllumination.Lightmapping:RequestLights(Light[], IntPtr, Int32)
    First I thought it would be a case of changing the settings in Rendering -> Light Settings, but when this didn't make a difference I went through every mesh renderer in the scene to make sure that "Contribute Global Illumination" is turned off, now that's done and the error is still being reported, is there anywhere else I can go to make sure this error is no longer reported?

    Using Unity 2019.3.5f1 and URP 7.1.8
     
    phobos2077 and Daryoon like this.
  2. SniperED007

    SniperED007

    Joined:
    Sep 29, 2013
    Posts:
    179
    I have the same issue, did you find a fix?
     
  3. Tim-C

    Tim-C

    Unity Technologies

    Joined:
    Feb 6, 2010
    Posts:
    2,158
  4. andrew210

    andrew210

    Joined:
    Apr 23, 2014
    Posts:
    175
    I just ended up doing a new scene and copying everything across into the new scene and it stopped giving me that error
     
  5. SniperED007

    SniperED007

    Joined:
    Sep 29, 2013
    Posts:
    179
  6. Brady

    Brady

    Joined:
    Sep 25, 2008
    Posts:
    2,385
    *Bump* As SniperED007 said, how do you actually go about disabling this? It doesn't help just to link to a thread about it being removed. My console is being spammed by warnings about this, but I can't find anywhere to disable (or for that matter enable) realtime GI in the lighting settings. It's only certain scenes exhibiting this. My suspicion is that this was removed from the UI without ensuring that the corresponding setting gets set to disabled, resulting in a situation where if you have a scene created in an earlier version of Unity and it was turned on, there's no longer a way to unset this setting, so you're doomed to get spammed warnings you can't do anything about.

    EDIT: I pulled the .unity scene file into Visual Studio and found the following:
    Code (csharp):
    1.  
    2. LightmapSettings:
    3.   m_ObjectHideFlags: 0
    4.   serializedVersion: 11
    5.   m_GIWorkflowMode: 1
    6.   m_GISettings:
    7.     serializedVersion: 2
    8.     m_BounceScale: 1
    9.     m_IndirectOutputScale: 1
    10.     m_AlbedoBoost: 1.17
    11.     m_EnvironmentLightingMode: 0
    12.     m_EnableBakedLightmaps: 0
    13.     m_EnableRealtimeLightmaps: 1
    I'm guessing that last line needs to be set to 0? I haven't done a build to test this yet, but looking at other scenes I have that don't cause the warning, this is set to 0. Fingers crossed...
     
    Last edited: Apr 17, 2020
  7. andrew210

    andrew210

    Joined:
    Apr 23, 2014
    Posts:
    175
    Abandoning the scene that was spewing the messages, copying all my prefabs across from the original scene, fixed it for me (although the lighting window on the old and new scene looks identical)
     
    phobos2077 likes this.
  8. phobos2077

    phobos2077

    Joined:
    Feb 10, 2018
    Posts:
    225
    This solution worked for me as well. Was loading the scene from an AssetBundle (via Addressables) and started getting this error after calling SetActiveScene(). Lighting should change when the loaded scene activates, but with this warning - it did not happen. After duplicating another scene that did not have the error and copying everything manually (objects and lighting settings), the warning disappeared and lighting change worked again.

    Note that I've only encountered this after moving this scene from Scenes in Build to Addressables. The scene itself was not changed, that's the weirdest part.
     
  9. Brady

    Brady

    Joined:
    Sep 25, 2008
    Posts:
    2,385
    Just as an update, my approach of just changing that line in my post above ("m_EnableRealtimeLightmaps:") to 0 fixed it.
     
    pdinklag, andrew210 and phobos2077 like this.
  10. pdinklag

    pdinklag

    Joined:
    Jan 24, 2017
    Posts:
    79
    Same here! I just moved to Addressables two weeks ago and only now this happened, and only in the player, not the editor.

    Luckily, this seems to help, thanks!
     
unityunity