Search Unity

Realtime GI disables on Play

Discussion in 'Global Illumination' started by Velcrohead, Aug 21, 2018.

  1. Velcrohead

    Velcrohead

    Joined:
    Apr 26, 2014
    Posts:
    72
    This has been bugging me for a while now but I've finally pinpointed what the issue is.

    When I bake realtime GI, and sit in the editor, the environment looks great.

    When I press play, the realtime GI toggle turns off, and the lighting goes to crap. I can turn it back on in the editor and suddenly it looks great again.

    Can't see any way to toggle this myself at run time (this also happens in builds).

    Anyone know what's causing it?
     
  2. kristijonas_unity

    kristijonas_unity

    Unity Technologies

    Joined:
    Feb 8, 2018
    Posts:
    412
    This is a known issue - https://issuetracker.unity3d.com/issues/materials-albedo-ignored-on-restart

    The fix should be available in the upcoming Unity 2018.2 and 2018.3 versions.

    Try disabling "Auto Generate" in the Lighting Settings, and bake the lighting manually. This should fix the issue you are having.
     
unityunity