Search Unity

  1. Engage, network and learn at Unite Austin 2017, Oct 3 - 5. Get your ticket today!
    Dismiss Notice
  2. Introducing the Unity Essentials Packs! Find out more.
    Dismiss Notice
  3. Check out all the fixes for 5.6 on the patch releases page.
    Dismiss Notice
  4. Unity 2017.1 is now released.
    Dismiss Notice
  5. Unity 2017.2 beta is now available for download.
    Dismiss Notice

Really strange fading bug when switching between Post Processing Profiles

Discussion in 'Cinemachine' started by Drowning-Monkeys, Sep 14, 2017.

  1. Drowning-Monkeys

    Drowning-Monkeys

    Joined:
    Mar 6, 2013
    Posts:
    252
    Hi there,

    So this only happens on my PC, not my Mac.
    I have two CM VCams set up with two different Post FX Profiles. The only difference is depth of field. When timeline switches or blends between the two cams, the screen goes black and the camera "fades in" over the course of about a second. Any idea what that could be?

    Edit - only happens in play mode, not in the editor
     
  2. Gregoryl

    Gregoryl

    Unity Technologies

    Joined:
    Dec 22, 2016
    Posts:
    310
    It might be a bug in PostProcessing. We're looking into it.
     
  3. Drowning-Monkeys

    Drowning-Monkeys

    Joined:
    Mar 6, 2013
    Posts:
    252
    okay so, just confirming - you've seen this and can reproduce it?
     
  4. Gregoryl

    Gregoryl

    Unity Technologies

    Joined:
    Dec 22, 2016
    Posts:
    310
    This is indeed a bug in PostProcessing, related to auto-exposure. It's been fixed on GitHub, but the fix hasn't been pushed to the AssetStore.
     
  5. Drowning-Monkeys

    Drowning-Monkeys

    Joined:
    Mar 6, 2013
    Posts:
    252
    okay i figured it out - it happens when two profiles have Eye Adaptation on them

    hah, you beat me to it :0