Search Unity

[RC3] Deadlock when entering playmode 2nd attempt. First Attempt works.

Discussion in 'Unity 5 Pre-order Beta' started by Maskawanian, Mar 1, 2015.

  1. Maskawanian

    Maskawanian

    Joined:
    Mar 5, 2014
    Posts:
    6
    I am getting a deadlock when entering playmode after exiting it the first time. This is with RC3.

    Steps to recreate:
    1. Open my game project.
    2. Start game.
    3. Stop game.
    4. Start game.

    What I have tried so far is delete the library and recreate all that data.
    Does not happen with an empty project.
    Even odder now, if I have a different scene load the one that was deadlocking immediately after loading it never freezes.
    Attempted to attach the UnityVS debugger and pause when this happens. The UnityVS debugger just hangs until I force quit the Unity Editor.
    Attempted to attach the MonoDevelop debugger and pause when this happens. The monodevelop debugger gives the following exception:

    Mono.Debugger.Soft.ObjectCollectedException: The requested operation cannot be completed because the object has been garbage collected.

    at Mono.Debugger.Soft.VirtualMachine.ErrorHandler(Object sender, ErrorHandlerEventArgs args) in c:\buildslave\monodevelop\build\monodevelop\main\contrib\Mono.Debugger.Soft\Mono.Debugger.Soft\VirtualMachine.cs:line 309

    at Mono.Debugger.Soft.Connection.SendReceive(CommandSet command_set, Int32 command, PacketWriter packet) in c:\buildslave\monodevelop\build\monodevelop\main\contrib\Mono.Debugger.Soft\Mono.Debugger.Soft\Connection.cs:line 1445

    at Mono.Debugger.Soft.Connection.Thread_GetState(Int64 id) in c:\buildslave\monodevelop\build\monodevelop\main\contrib\Mono.Debugger.Soft\Mono.Debugger.Soft\Connection.cs:line 1902

    at Mono.Debugger.Soft.ThreadMirror.get_ThreadState() in c:\buildslave\monodevelop\build\monodevelop\main\contrib\Mono.Debugger.Soft\Mono.Debugger.Soft\ThreadMirror.cs:line 50

    at Mono.Debugging.Soft.SoftDebuggerSession.ThreadIsAlive(ThreadMirror thread) in c:\buildslave\monodevelop\build\monodevelop\main\src\addins\MonoDevelop.Debugger.Soft\Mono.Debugging.Soft\SoftDebuggerSession.cs:line 2130

    at Mono.Debugging.Soft.SoftDebuggerSession.EnsureRecentThreadIsValid(ProcessInfo process) in c:\buildslave\monodevelop\build\monodevelop\main\src\addins\MonoDevelop.Debugger.Soft\Mono.Debugging.Soft\SoftDebuggerSession.cs:line 2103

    at Mono.Debugging.Soft.SoftDebuggerSession.OnStop() in c:\buildslave\monodevelop\build\monodevelop\main\src\addins\MonoDevelop.Debugger.Soft\Mono.Debugging.Soft\SoftDebuggerSession.cs:line 2092

    at Mono.Debugging.Client.DebuggerSession.<Stop>b__35() in c:\buildslave\monodevelop\build\monodevelop\main\src\core\Mono.Debugging\Mono.Debugging.Client\DebuggerSession.cs:line 707

    Short of uploading my 11.4 GB project as a bug report does anyone have any suggestions?

    Thanks.
     
    Last edited: Mar 1, 2015
  2. Maskawanian

    Maskawanian

    Joined:
    Mar 5, 2014
    Posts:
    6
    I tried using WinDbg to find out where it stalled, but I'm not sure if this is just the .net binary running or what since there are no symbols...

    Code (CSharp):
    1. (1e5c.1da4): Break instruction exception - code 80000003 (first chance)
    2. ntdll!DbgBreakPoint:
    3. 00007ffa`e72131a0 cc              int     3
    4.  
     
  3. Maskawanian

    Maskawanian

    Joined:
    Mar 5, 2014
    Posts:
    6
    I was unable to get the .net clr extensions (psscor) to run in windbg for the unity editor, either due to mono or my not understanding the program having never used it before. Hopefully someone here will have some advice on how to proceed.
     
unityunity