Search Unity

  1. Calling all beginners! Join the FPS Beginners Mods Challenge until December 13.
    Dismiss Notice
  2. It's Cyber Week at the Asset Store!
    Dismiss Notice

Quest + LWRP: MSAA not working

Discussion in 'AR/VR (XR) Discussion' started by DanjelRicci, Nov 30, 2019.

  1. DanjelRicci

    DanjelRicci

    Joined:
    Mar 8, 2010
    Posts:
    172
    Pretty much as the title says, I'm using Unity 2019.14f1, Oculus Integration 1.43, LWRP 6.9.1.
    Setting MSAA in the LWRP settings to any value (2x, 4x, 8x) does nothing. All cameras have MSAA set to Use Pipeline Settings. OVRManager has Use Recommended MSAA set to false. I'm not using any PostProcessing package. What am I missing?
     
  2. hawken

    hawken

    Joined:
    Aug 22, 2013
    Posts:
    501
    MSAA is currently unsupported in LWRP in VR.
     
  3. DanjelRicci

    DanjelRicci

    Joined:
    Mar 8, 2010
    Posts:
    172
    So there is no way of having antialiasing with LWRP and VR? MSAA is the only antialiasing option available as far as I can tell, when using LWRP.
     
  4. nomand

    nomand

    Joined:
    Dec 23, 2008
    Posts:
    27
    Strange, I've used it with LWRP and now with URP in exactly that way, camera set to use pipeline, ovrmanager to false, URP asset set to 8x, works fine. Check that the camera you're rendering from is tagged Main Camera, make sure your render pipeline asset is also set in Quality project settings under Rendering (not just Graphics Settings) although I doubt it should matter.
     
  5. hawken

    hawken

    Joined:
    Aug 22, 2013
    Posts:
    501
    I used this trick for a bit then it stopped working on some update. It's hard to know which versions are compatible with each other... out of interest which LWRP / Unity / OVR version mix are you getting this to work with?
     
  6. DanjelRicci

    DanjelRicci

    Joined:
    Mar 8, 2010
    Posts:
    172
    I had set everything exactly like that, it just won’t work. Actually not even Post Processing antialiasing is working... I’m left with no choice to revert to default pipeline then? It escapes me why we should even use LWRP in VR if no form of antialiasing is working.
    Unless this depends on the stereo rendering mode? I’m using Single Pass now.
    EDIT sorry, I'm using Multiview. Single Pass renders the right eye deformed, and Multi Pass doesn't render the right eye at all (still in both cases AA didn't work).
     
    Last edited: Dec 3, 2019 at 6:50 PM
  7. nomand

    nomand

    Joined:
    Dec 23, 2008
    Posts:
    27
    My current setup with MSAA working:
    Unity 2019.3.0f1
    URP 7.1.6
    Relevant URP settings:
    Depth texture on
    HDR off
    MSAA 4x
    Render Scale 1
    Main Light per pixel, Cast shadows on, 1024 res with no additional lights.

    Not using OVRManager:
    Tracked Pose Driver on a camera with settings:
    Renderer set to URP_Renderer in the dropdown
    Opaque + Depth texture "Use Pipeline"
    HDR, MSAA "Use Pipeline"

    If using OVRManager:
    Use Recommended MSAA off.
    Same camera settings as above.
     
    DanjelRicci and Claytonious like this.
  8. DanjelRicci

    DanjelRicci

    Joined:
    Mar 8, 2010
    Posts:
    172
    Thanks a lot. I'd like to avoid updating to 2019.3 and to URP in this moment because I've already spent a lot of time trying to get things working rather than working on the actual game... I guess I'll do it later. I had all sorts of issues with Quest and 2019.3 beta previously, might need to check again what changed for the final release.
     
  9. nomand

    nomand

    Joined:
    Dec 23, 2008
    Posts:
    27
    I wouldn't recommend it yet, both multiview and multipass are broken, but MSAA is definitely working. I was using exactly the same setup in 19.2.12 LWRP before porting to URP, and it worked then too.
     
  10. hawken

    hawken

    Joined:
    Aug 22, 2013
    Posts:
    501
    ahh... must be a 2019.1 problem