Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice
  3. Dismiss Notice

Question Python packages stuck on Compiling Requirements

Discussion in 'Editor & General Support' started by LazerDragoon, Mar 22, 2024.

  1. LazerDragoon

    LazerDragoon

    Joined:
    May 2, 2019
    Posts:
    1
    Hello, recently I've been trying to get python to run in the editor using the python for unity package (https://docs.unity3d.com/Packages/com.unity.scripting.python@4.0/manual/index.html). I used a requirements.txt to install the python packages that I needed but it gets stuck Compiling Requirements. I let it run for a long time and it never finished. I tried installing certain packages manually as well, with the Spawn shell in environment option, and it seems like it has an issue with tensorflow. Does this package work with unity python scripting, or am I doing something wrong. Thanks for any help.

    requirements.txt

    absl-py==2.1.0
    anyio==4.2.0
    argon2-cffi==23.1.0
    argon2-cffi-bindings==21.2.0
    arrow==1.3.0
    asttokens==2.4.1
    astunparse==1.6.3
    async-lru==2.0.4
    attrs==23.2.0
    Babel==2.14.0
    backcall==0.2.0
    beautifulsoup4==4.12.2
    bleach==6.1.0
    cachetools==5.3.2
    certifi==2023.11.17
    cffi==1.16.0
    charset-normalizer==3.3.2
    click==8.1.7
    colorama==0.4.6
    comm==0.2.1
    contourpy==1.1.1
    cycler==0.12.1
    debugpy==1.8.0
    decorator==5.1.1
    defusedxml==0.7.1
    exceptiongroup==1.2.0
    executing==2.0.1
    fastjsonschema==2.19.1
    filelock==3.9.0
    flatbuffers==23.5.26
    fonttools==4.48.1
    fqdn==1.5.1
    fsspec==2023.4.0
    gast==0.4.0
    google-auth==2.26.2
    google-auth-oauthlib==1.0.0
    google-pasta==0.2.0
    grpcio==1.60.0
    h5py==3.10.0
    idna==3.6
    importlib-metadata==7.0.1
    importlib-resources==6.1.1
    ipykernel==6.28.0
    ipython==8.12.3
    ipywidgets==8.1.1
    isoduration==20.11.0
    jedi==0.19.1
    Jinja2==3.1.3
    joblib==1.3.2
    json5==0.9.14
    jsonpointer==2.4
    jsonschema==4.20.0
    jsonschema-specifications==2023.12.1
    jupyter==1.0.0
    jupyter-console==6.6.3
    jupyter-events==0.9.0
    jupyter-lsp==2.2.1
    jupyter_client==8.6.0
    jupyter_core==5.7.1
    jupyter_server==2.12.4
    jupyter_server_terminals==0.5.1
    jupyterlab==4.0.10
    jupyterlab-widgets==3.0.9
    jupyterlab_pygments==0.3.0
    jupyterlab_server==2.25.2
    keras==2.13.1
    kiwisolver==1.4.5
    libclang==16.0.6
    Markdown==3.5.2
    MarkupSafe==2.1.3
    matplotlib==3.7.4
    matplotlib-inline==0.1.6
    mistune==3.0.2
    mpmath==1.3.0
    nbclient==0.9.0
    nbconvert==7.14.1
    nbformat==5.9.2
    nest-asyncio==1.5.9
    networkx==3.0
    nltk==3.8.1
    notebook==7.0.6
    notebook_shim==0.2.3
    numpy==1.24.3
    oauthlib==3.2.2
    opt-einsum==3.3.0
    overrides==7.4.0
    packaging==23.2
    pandas==2.0.3
    pandocfilters==1.5.0
    parso==0.8.3
    pickleshare==0.7.5
    pillow==10.2.0
    pkgutil_resolve_name==1.3.10
    platformdirs==4.1.0
    prometheus-client==0.19.0
    prompt-toolkit==3.0.43
    protobuf==4.25.2
    psutil==5.9.7
    pure-eval==0.2.2
    pyasn1==0.5.1
    pyasn1-modules==0.3.0
    pycparser==2.21
    pydotplus==2.0.2
    Pygments==2.17.2
    pyparsing==3.1.1
    python-dateutil==2.8.2
    python-json-logger==2.0.7
    pytz==2023.3.post1
    pywin32==306
    pywinpty==2.0.12
    PyYAML==6.0.1
    pyzmq==25.1.2
    qtconsole==5.5.1
    QtPy==2.4.1
    referencing==0.32.1
    regex==2023.12.25
    requests==2.31.0
    requests-oauthlib==1.3.1
    rfc3339-validator==0.1.4
    rfc3986-validator==0.1.1
    rpds-py==0.17.1
    rsa==4.9
    scikit-learn==1.3.2
    scipy==1.10.1
    Send2Trash==1.8.2
    six==1.16.0
    sniffio==1.3.0
    soupsieve==2.5
    stack-data==0.6.3
    sympy==1.12
    tensorboard==2.13.0
    tensorboard-data-server==0.7.2
    tensorflow==2.13.0
    tensorflow-estimator==2.13.0
    tensorflow-intel==2.13.0
    tensorflow-io-gcs-filesystem==0.31.0
    termcolor==2.4.0
    terminado==0.18.0
    threadpoolctl==3.2.0
    tinycss2==1.2.1
    tomli==2.0.1
    torch==2.2.0+cu121
    torchaudio==2.2.0+cu121
    torchvision==0.17.0+cu121
    tornado==6.4
    tqdm==4.66.2
    traitlets==5.14.1
    types-python-dateutil==2.8.19.20240106
    typing_extensions==4.8.0
    tzdata==2023.4
    uri-template==1.3.0
    urllib3==2.1.0
    wcwidth==0.2.13
    webcolors==1.13
    webencodings==0.5.1
    websocket-client==1.7.0
    Werkzeug==3.0.1
    widgetsnbextension==4.0.9
    wrapt==1.16.0
    yellowbrick==1.5
    zipp==3.17.0
     

    Attached Files: