Search Unity

Question Python Low Level API, error with no_graphics=True

Discussion in 'ML-Agents' started by setsailforfail, Nov 8, 2023.

  1. setsailforfail

    setsailforfail

    Joined:
    Nov 8, 2023
    Posts:
    1
    Hello,

    I am using the Python Low Level API to create my own training algorithm for an agent to solve an environment. In this case, it is the 3D Ball environment. Since I am using multiple instances to speed up the training, I want to avoid showing the graphics for each environment. However, when I am using the no_graphics=True in the UnityEnvironment, I get the following error (for each environment that is created):

    ERROR: Shader Legacy Shaders/VertexLit shader is not supported on this GPU (none of subshaders/fallbacks are suitable)
    WARNING: Shader Unsupported: 'Autodesk Interactive' - All subshaders removed
    WARNING: Shader Did you use #pragma only_renderers and omit this platform?
    WARNING: Shader If subshaders removal was intentional, you may have forgotten turning Fallback off?
    ERROR: Shader Autodesk Interactive shader is not supported on this GPU (none of subshaders/fallbacks are suitable)
    WARNING: Shader Unsupported: 'Autodesk Interactive' - All subshaders removed
    WARNING: Shader Did you use #pragma only_renderers and omit this platform?
    WARNING: Shader If subshaders removal was intentional, you may have forgotten turning Fallback off?
    WARNING: Shader Unsupported: 'Standard' - All subshaders removed
    WARNING: Shader Did you use #pragma only_renderers and omit this platform?
    WARNING: Shader If subshaders removal was intentional, you may have forgotten turning Fallback off?
    ERROR: Shader Standard shader is not supported on this GPU (none of subshaders/fallbacks are suitable)
    WARNING: Shader Unsupported: 'Standard' - All subshaders removed
    WARNING: Shader Did you use #pragma only_renderers and omit this platform?
    WARNING: Shader If subshaders removal was intentional, you may have forgotten turning Fallback

    Any idea how I can get rid of that? This error does not appear when I use graphics.