Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice

Third Party [PUN2 / Local] Unchecking "Use Name Server" causes "Failed parsing address" error

Discussion in 'Multiplayer' started by PascalTheDog, Mar 4, 2022.

  1. PascalTheDog

    PascalTheDog

    Joined:
    Mar 16, 2015
    Posts:
    86
    Hey,

    I've set up a bunch of local servers on premise, and they all seem to be working fine. I can set the IP address in-app using my GUI, and then it connects and creates-joins a room.

    In the PhotonServerSettings, I had forgotten to uncheck "Use Name Server" and I got that warning pop-up message every time I tried running my scene in the Editor as a result. So I went and unchecked it; after all, that's what it says I should do in the field summary.

    But now it throws an error and won't connect: Failed parsing address: 192.168.1.XX, XX being whatever I set as the IP address in-app. Here is the complete error log. Does anyone have any idea what's going on? I should stress that my local servers seem to be working fine when "Use Name Server" is checked (which shouldn't actually happen, from what I gather).

    Assistance would be greatly appreciated. Cheers!
     
  2. tobiass

    tobiass

    Joined:
    Apr 7, 2009
    Posts:
    3,079
    If you are running a v5 Photon Server, you also run a Name Server by default, so UseNameServer should be true.
    The address may have leading or trailing spaces in it? Recently stumbled over that myself. This is not trimmed.