Search Unity

  1. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice
  2. Ever participated in one our Game Jams? Want pointers on your project? Our Evangelists will be available on Friday to give feedback. Come share your games with us!
    Dismiss Notice

PSA: Latest supported Unity release for EditorXR is 2018.3 (minimum version)

Discussion in 'EditorXR' started by mtschoen, Feb 27, 2019.

  1. mtschoen

    mtschoen

    Unity Technologies

    Joined:
    Aug 16, 2016
    Posts:
    42
    The currently supported Unity release range for EditorXR is 2017.3 - 2018.3
     
    SatishGodaPearl likes this.
  2. jorisweijdom

    jorisweijdom

    Joined:
    Aug 7, 2017
    Posts:
    5
  3. amirebrahimi_unity

    amirebrahimi_unity

    Unity Technologies

    Joined:
    Aug 12, 2015
    Posts:
    339
    What version of the SteamVR plugin have you installed?
     
  4. PixelPup

    PixelPup

    Joined:
    Mar 6, 2018
    Posts:
    18
    Awesome, very excited to try this out on 2018.3. I had stopped using it as too many projects had things in 2018 I needed. Glad to see this.
     
  5. jorisweijdom

    jorisweijdom

    Joined:
    Aug 7, 2017
    Posts:
    5
    Hi Amir, sorry for my late reply. As you have recommended in the documentation I use the old SteamVR plugin (1.2.3)...
    Any ideas?
     
  6. amirebrahimi_unity

    amirebrahimi_unity

    Unity Technologies

    Joined:
    Aug 12, 2015
    Posts:
    339
    You should be using the old SteamVR plugin. Those errors you are seeing are benign. Do you get output to your HMD? If not, have you tried toggling the "Device View" in the lower left corner?
     
  7. JDelekto

    JDelekto

    Joined:
    Jan 7, 2017
    Posts:
    30
    Is 2018.3 still a requirement for Unity XR Editor? I have installed 2018.4.22f1 which is the current LTS release, but I will go back and install the latest 2018.3.14 from the archive if necessary (unless there is a specific patch level of 2018.3 that is required).
     
  8. amirebrahimi_unity

    amirebrahimi_unity

    Unity Technologies

    Joined:
    Aug 12, 2015
    Posts:
    339
    No, 2018.4.22f1 should work fine. I've updated the title of this thread to denote that it is only the minimum version required to use EditorXR.
     
  9. JDelekto

    JDelekto

    Joined:
    Jan 7, 2017
    Posts:
    30
    Oh excellent, that being said, so 2019.3 should be good as well?
     
  10. amirebrahimi_unity

    amirebrahimi_unity

    Unity Technologies

    Joined:
    Aug 12, 2015
    Posts:
    339
    Yes
     
unityunity