Search Unity

Projects don't detect Unity Plus license (just Personal)

Discussion in 'Editor & General Support' started by Kubold, May 18, 2019.

  1. Kubold

    Kubold

    Joined:
    May 10, 2012
    Posts:
    339
    Since today, after a Windows 10 update, the Editor (2019.1.1f3, 2019.1.3f1) works only using Personal license, despite the fact that I have a Unity Plus license.

    Unity Hub 2.0 detects Unity Plus license, it's just the editor does not. If I click "manage licenses" in the Editor, it opens Unity Hub, which says I have a Unity Plus license, so I can't do anything about it.

    I tried re-installing hub and editor, did not help. I tried revoking all the license seats and assigning them again, did not help either.

    I have a pre-paid Unity Plus license from Oculus Start program, which should last for another 9 months. The problem started after Windows updated.

    Bug Case 1155621.
     
  2. FWCorey

    FWCorey

    Joined:
    Feb 2, 2011
    Posts:
    33
    I'm getting the same issue with Unity 2019.3.0b1
    I have an active subscription to Plus. Works fine on one computer, but on my second computer, Hub detects the license but the Editor does not.

    Found the solution in another post:

    1. Quit Unity Editor if running
    2. Quit Unity Hub if running
    3. Delete the folder "C:\ProgramData\Unity" (It only has one file in it)
    4. Start Unity Hub, it will ask you to activate your license again.
    After that you should be able to open your project in the Editor with Plus/Pro enabled normally again!
     
    Last edited: Aug 31, 2019