Search Unity

  1. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice
  2. Ever participated in one our Game Jams? Want pointers on your project? Our Evangelists will be available on Friday to give feedback. Come share your games with us!
    Dismiss Notice

Projectors in 5.4.0p1 are broken

Discussion in 'Editor & General Support' started by captainpickle, Aug 18, 2016.

  1. captainpickle

    captainpickle

    Joined:
    Oct 5, 2013
    Posts:
    13
    I just spent a few hours tracking down an odd rendering issue after upgrading from 5.3.3p3 to 5.4.0p1 and unfortunately this looks like a show-stopping bug (and we'll have to downgrade back to 5.3): A projector will render all of its affected objects 2x if there are any alpha blended materials visible on screen. You can see this easily in the frame debugger (does not happen on 5.3.3p3). I've submitted a bug report.

    If anyone wants to see this I've attached two projects (they are identical with the exception that one is meant for 5.4.0p1 and the other is for 5.3.3p3). You'll see very different (and correct) behavior in 5.3.3p3.
     

    Attached Files:

    Last edited: Aug 18, 2016
  2. shawn

    shawn

    Unity Technologies

    Joined:
    Aug 4, 2007
    Posts:
    551
    Hey, what's the case number for the bug report you submitted?
     
  3. captainpickle

    captainpickle

    Joined:
    Oct 5, 2013
    Posts:
    13
    Hi Shawn,

    Case 824041
     
  4. captainpickle

    captainpickle

    Joined:
    Oct 5, 2013
    Posts:
    13
    Just got a reply from Unity QA saying that this issue is a dupe of another issue, that has been open for a year?

    https://issuetracker.unity3d.com/is...e-is-any-transparent-object-visible-to-camera

    First a couple questions: my bug doesn't happen in 5.3.3p3, it only happens in 5.4 - but the bug linked above is from 5.2?
    Why is that bug not marked as a regression? Clearly it's a regression in behavior?

    Why hasn't it been fixed in a year?
     
  5. shawn

    shawn

    Unity Technologies

    Joined:
    Aug 4, 2007
    Posts:
    551
    Yeah, I noticed this too and asked QA to double check. It's possible that this was actually fixed and then regressed again. Or only fixed in a 5.3 patch release and didn't make it to 5.4 properly.

    Many bugs haven't been fixed in even longer. Bugs get prioritized based on many factors, one of the biggest is how many people it affects. Unfortunately, projectors are not heavily used anymore in Unity, so that lowers the prioritization of this bug. With that said, after we figure out what's going on with the discrepancy regrading 5.3.3p3, I'll poke the graphics team again to re-evaluate this bug.
     
  6. captainpickle

    captainpickle

    Joined:
    Oct 5, 2013
    Posts:
    13
    Thanks Shawn I do hope it gets fixed in a patch - we can't move to the latest version without this feature and there's really no solution without it.

    As a customer though, I am concerned. I'm paying monthly for software that I can't use. Obviously there is no guarantee that a feature won't get broken -- BUT as a customer I am in a very difficult situation when there is no guarantee that you guys will fix existing functionality that was broken in new builds. That makes upgrading to new versions an incredibly risky thing to do.

    Frankly I'm terrified that there are "lots of bugs like this" that are regressions in functionality that just sit there ignored for a year or even longer.

    Does premium support give us a way to escalate issues?
     
  7. shawn

    shawn

    Unity Technologies

    Joined:
    Aug 4, 2007
    Posts:
    551
    Your concern is understandable. The majority of long standing bugs are bugs that have existed since the introduction of whatever feature they are in and have relative low impact. We automatically escalate bugs that are regressions. If your bug proves to be a regression as suspected (I'm still waiting to hear back about it), it's much more likely to get fixed.
     
  8. bluescrn

    bluescrn

    Joined:
    Feb 25, 2013
    Posts:
    519
    Don't suppose anyone's figured out a workaround for this? - I've just run into it on 5.4.0f3
     
  9. captainpickle

    captainpickle

    Joined:
    Oct 5, 2013
    Posts:
    13
    If you can go back to 5.3.6p2 it works there. It's broken in Unity 5.4, and IMO their QA mis-categorized the issue as one that occurs all the way back in 5.2 (that is not marked as a regression, despite it clearly being one).
     
  10. captainpickle

    captainpickle

    Joined:
    Oct 5, 2013
    Posts:
    13
    @shawn did you ever get a response about this issue?
     
  11. shawn

    shawn

    Unity Technologies

    Joined:
    Aug 4, 2007
    Posts:
    551
  12. sfaok

    sfaok

    Joined:
    Nov 27, 2012
    Posts:
    21
unityunity