Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Question "Project failed to open. Please check the logs" upon project creation

Discussion in 'Getting Started' started by mathiasyigzaw, Nov 5, 2023.

  1. mathiasyigzaw

    mathiasyigzaw

    Joined:
    Nov 5, 2023
    Posts:
    1
    Hello kind people of the forums!

    I'm brand new to Unity and have pretty basic computer knowledge. I've been trying to open my first project on the Unity Hub, and it keeps popping up an error message that says "Project failed to open. project could not be opened. Please check the logs." no matter what I try.

    For context, I'm using a Macbook Pro (from 2013, I think) running High Sierra 10.13.6, with the most recent version of Unity Hub and I've trying to use both the 2023.1.19f1 and 2022.3.12f1 versions of the editor. This laptop is a family member's and it's pretty old, but has a huge amount of storage and a decent amount of RAM. I've been trying to create a project using the 3D core and the 2023.1.19f1 editor for a college course I'm currently in, and my professor is very unhelpful in helping me troubleshoot but expects me to have projects completed soon, so I'm getting desperate. Every time I try to start a "new project," it will pull up the new project in Unity Hub, but will not create a file in the folder I'm directing to. Similarly, if I start a new project, get the error message, and restart the hub, the project is gone from the hub. I have administrative access on this computer/profile, so it should allow me to create new files (and it does with other programs). I have tried reading the logs, as the message says to, but with my limited knowledge, I don't understand what most of it means. The end of the log seems to include a bunch of error codes, which I've tried googling, but all of the suggestions I've seen in other forum posts haven't worked for me. Here's a picture of the end of the log.

    Screen Shot 2023-11-02 at 4.23.46 PM.png
    Here's what I've already tried (that I can remember): Uninstalling hub, editor, and all traces of Unity, then reinstalling from scratch; Updating my computer; Restarting my computer; Restarting Unity Hub; Returning and reinstating private license; Using an older version on editor; Using a different wifi network.
    I would greatly appreciate any insight that anyone could give!! I've been trying to fix this issue for days at this point, and I'm now very behind in my class and reaching my wit's end. Sorry this post is so long, I just wanted to provide as much context as I can! Thanks :)
     

    Attached Files:

  2. icytrue

    icytrue

    Joined:
    Dec 27, 2023
    Posts:
    1
    I have the exact same issue and have tried the same steps (before I saw your Post). Main difference is I'm using an MacBook Air M1, but otherwise the story is the same.

    I am hoping this extra comment will bump the thread and someone who can help will see it!