Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice
  3. Dismiss Notice

Question Project Crashing System

Discussion in 'Editor & General Support' started by Zentisca, Apr 13, 2024.

  1. Zentisca

    Zentisca

    Joined:
    Jul 18, 2022
    Posts:
    3
    G'day all.

    I'll start with the TL;DR incase anyone has dealt with this before:
    When I'm in a scene, adding prefabs to it, or removing prefabs, my computer freezes, and still sometimes Blue Screens, or just require me to hard reset it, as everything locks up (Audio, Display + Inputs).

    Long version:
    *re-edit
    Turns out I shouldn't be trusting the Q-Code. (Turns out, it monitors Temps.. just a coincidence that I got a Blue Screen Memory Error )
    However, I did have 1 bluescreen refer to memory (I can't remember the specific stop code for it), every other crash was Stop_Watch (or whatever it is)

    I am at a loss of what to do.
    I have tried everything under the sun, and I really, REALLY don't want to format my PC, unless it is the absolute last option.

    As for any other possible questions for troubleshooting:

    Is it just this Project doing it: So far, yes. Previously I had it crash in blender once, but aside form that, and since the new RAM, it has crashed entirely though adding Prefabs and now, removing prefabs.

    Anything else in the project that may be corrupted: No, there isn't any corrupted files. I once crashed and my Unity project lost refence to all it's own files, after deleting the Library folder, and waiting a couple of hours, it managed to reopen the project.

    Current RAM and Motherboard + Ram Speeds: Mobo: Asus Strix z790-e gaming, RAM: Cosiar Vengence 4x32GB (Can't remember the exact code, but it's the only supported Cosair brand in 126 configuration for my motherboard) Ram speeds were XMP 2.0 5300MHz (auto set on install), I am currently on Auto (4800MHz) and have had 1 crash.

    Are drivers up to date: Yes, drivers are all up to date, including my BIOS.

    What version of Unity are you running: 2022.3.20f1 (3D, URP)

    Are you using any external tools in your project: No, I have imported a lot of assets, I did have Odin Inspector, but I have removed it long ago.

    Any help would be greatly appreciated, and I would buy you a virtual beer if any suggestions or help lead to fixing this issue.
     
    Last edited: Apr 13, 2024
  2. CodeSmile

    CodeSmile

    Joined:
    Apr 10, 2014
    Posts:
    6,922
    That's an issue with your system. Usually indicating a malfunctioning hardware or driver.

    Oh, hey, welcome to the club! ;)
    You're not the first to report stability issues with that CPU and when using Unity.

    Last person had to tweak BIOS settings because Intel allows (no: enforces) board manufacturers to overclock their CPU because otherwise it'd be only 5% faster than the 13900K. The 14900K requires excellent cooling and high quality components, specifically PSU. At least 850W is minimum, which should be sufficient together with a 4070.

    Mine is stable but wasn't perfectly stable when I tried out its "AI overclocking" feature. It froze maybe twice a week or so and eventually I disabled and uninstalled the Intel tweaking tool. Stable since. I still have 6 GHz single-core overclocking enabled in BIOS.

    What you can do:
    Run Prime95 (max heat) and Furmark (burn in) simultaneously for about two hours. If this doesn't crash the system, great! If it does: also great because you can now make adjustments, primarily in BIOS, until it is stable. Mainly look up what boards default to that make the CPU overshoot its limits and change that setting to behave similar to the 13900K series. I believe this involves simply lowering the power limits, ie max turbo for 8s rather than 200s or even indefinite, leaving it up to thermal throttling to kick in eventually.

    You should also get a copy of memtest86 and run a full/complete test overnight (will probably take 10 hours for 128 gigs). I think they provide that so you can run boot it from USB stick. If there are no errors you can be 99.999999% certain that the memory is OK.