Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. We’re making changes to the Unity Runtime Fee pricing policy that we announced on September 12th. Access our latest thread for more information!
    Dismiss Notice
  3. Dismiss Notice

ProGrids /ProBuilder always snaps even if turned off

Discussion in 'World Building' started by Link_95, Jan 26, 2021.

  1. Link_95


    Dec 23, 2020
    since friday i cant build or move anything without grid/snap i can change the grid/snap-size via the ProGrids options but no matter if it is turned on or off im stuck to the snaps did i messed something up without noticing?

    I made a new 3d project and got nothing loaded in exepte of ProGrids and ProBuilder.

    and if i press "v" and drag an object it is stuck to the grid for 4-5m then it is smooth without snap but only on straight lines diagonals dont work.
    EdithMerley likes this.
  2. ThomasLopez


    Unity Technologies

    Jun 8, 2020
    Hi @Link_95 ,
    Which Unity and PB versions are you using?
    Did you do something on Friday that could explain a change (update of ProBuilder or ProGrid)?

    Have you enabled the snapping from Unity ? If I remember correct it can influence ProBuilder placement.
    It can only be enable/disable in the Global context.
    EdithMerley likes this.
  3. CJM821


    Jul 12, 2021
    Hey, has anyone found a solution for this, cause I opened my unity project and I was trying to make a table and it's forcing it to be either 1 or 0 when I'm trying to move the faces, progrids snapping is turned off, progrids also won't let you change the snap settings when editing a face of an object as it is grayed out, has anyone found a fix for this outside of pressing CTRL before grabbing the handles
    EdithMerley likes this.
  4. EdithMerley


    Feb 19, 2022
    This is happening to me as well. I'm using Unity 2019.4.36f1 Personal (64bit). I inset on a face of a cube and I'm trying to extrude the face out. The face will only travel a full grid square, even if ProGrids Snapping is disabled. If I move the entire cube, it can move normally without snapping so long as the ProGrids snapping is disabled. Interestingly, the "Toggle Grid Snapping on and off" icon to the right of "Toggle Tool Handle Rotation" remains unclickable no matter if it's set to Local or Global. Maybe that is because I'm using ProGrids and it is disabled to prevent conflict. Has anyone found a solution?

    Attached Files:

  5. FoodFish_


    May 3, 2018
    This is also blocking me