Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

ProGrids Panel - no option to show them after close

Discussion in 'World Building' started by algorithmicvertex, Mar 27, 2019.

  1. algorithmicvertex

    algorithmicvertex

    Joined:
    May 22, 2016
    Posts:
    6
    Hi all

    I clicked "Close" on the ProGrids Panel and now there is no option to show it again, using the Package Manager ProGrids version 3.0.3-preview.4, and Unity version 2018.3.7f1 Personal.

    What I did was click "Close" right below the "Perspective Grid" button, and the panel was hidden and I can't find a way to show the ProGrids panel again. Tried closing the tool and re-opening it, removing and uninstalling, changing ProGrid settings and still I can't find a way. The fun thing is the grid itself is showing.

    Any tips on how to show the panel again?

    Thank you
     
  2. gabrielw_unity

    gabrielw_unity

    Unity Technologies

    Joined:
    Feb 19, 2018
    Posts:
    882
    Hi! You should be able to click the bottom "tag" do bring that back:

    upload_2019-4-2_16-44-18.png
     
  3. DeSuper

    DeSuper

    Joined:
    Jan 31, 2020
    Posts:
    1
    Hi!

    When I closed and opened the Scene tab, the grids tab was back and stayed.

    Have fun!
     
    angryITGuy likes this.
  4. cmann

    cmann

    Joined:
    Aug 1, 2015
    Posts:
    30
    That button will sometimes disappear until Unity is restarted.
     
  5. angryITGuy

    angryITGuy

    Joined:
    Apr 16, 2020
    Posts:
    3
    Thanks for this, I was pulling my hair out.. Seems that the first time you use it, the "Grids" option is not shown, leaving users lost. Once you close the Scene tab and re-open it, the "Grids" option appears. If there was an option in the preferences for progrid to toggle it, that would save alot of messing about.
     
  6. jeffweber

    jeffweber

    Joined:
    Dec 17, 2009
    Posts:
    616
    FYI, for those reading this working in 2D mode. The ProGrid tools toggle also will not show if in 2D mode. You have to switch to 3D, click the toggle, then switch back to 2D.
     
    pr01dgy_imafrog likes this.
  7. snoutmate

    snoutmate

    Joined:
    Jan 27, 2019
    Posts:
    1
    Also the toggle won't show even in 3D mode if you're in orhographic view, which took me quite some time to figure out.
     
  8. mishasniper

    mishasniper

    Joined:
    Apr 14, 2013
    Posts:
    2
    No button "grids" after click "close" on GridPro UI.

    upload_2020-8-22_18-4-26.png
     
  9. rguerrasa

    rguerrasa

    Joined:
    Apr 21, 2020
    Posts:
    3
    Seems like it is definitely a bug of some sort. You actually have to CLOSE the Scene window. After the Scene Window is closed, you have to reopen it in Window->general->scene. Closing and reopening Unity does not help. Leaving the scene and reentering does not help either.
     
    baraterahul48 likes this.
  10. andyrev

    andyrev

    Joined:
    Oct 5, 2015
    Posts:
    2
    Hi all! You could just switch between perspective and normal view (axis at the top-right corner of the scene)
    progrid.png
     
  11. lrasomattos

    lrasomattos

    Joined:
    Aug 22, 2015
    Posts:
    26
    I had the same problem. After clicking "Close" the Scene HUD was gone, nowhere to be found.
    Closing the Scene Tab and opening a new one didn't work for me.

    What worked was closing ProGrids through the "Tools" menu. And then re-opening it.
    First:
    upload_2022-6-5_12-13-41.png
    Then:
    upload_2022-6-5_12-14-21.png

    Just clicking "ProGrids Window" would also not work before hitting "Close ProGrids" - which seems to have a different effect from the "Close" button n the Scene HUD (which was probably meant to be "Hide")
     
unityunity