Search Unity

  1. Unity 2019.1 is now released.
    Dismiss Notice

ProBuilder 3.0.9 Editor Lag/Stutter

Discussion in 'World Building' started by AMastryukov, Aug 12, 2018.

  1. AMastryukov

    AMastryukov

    Joined:
    May 21, 2017
    Posts:
    1
    I am having massive lag/stutter in the editor when using ProBuilder tools as well as when ProBuilder objects are present in a scene. It is frustrating to the point that ProBuilder becomes unusable. Having only 12 default cubes present in an empty scene results in very uncomfortable stutter.

    The only feedback I get is this type of warning in the console:
    ==============================================
    There are 12 objects in the Scene with overlapping UV's. Please see the details list below or use the 'UV Overlap' visualisation mode in the Scene View or Object Maps for more information.

    - Cube (10): 392 texels
    - Cube (2): 392 texels
    - Cube (5): 392 texels
    - Cube (9): 388 texels
    - Cube (8): 388 texels
    - Cube (3): 388 texels
    - Cube: 388 texels
    - Cube (6): 388 texels
    - Cube (4): 388 texels
    - Cube (7): 388 texels
    - Cube (1): 388 texels
    - Cube (11): 384 texels
    ==============================================

    I attempted to address these warnings using solutions proposed here https://forum.unity.com/threads/probuilder-2-9-8f3-this-gameobject-has-overlapping-uvs.533490/, but none of them solved either of the issues I was having.

    My computer specifications:
    Ryzen 5 2600X (3.6GHz), RX 580 8GB, 8GB RAM
     
  2. gabrielw_unity

    gabrielw_unity

    Unity Technologies

    Joined:
    Feb 19, 2018
    Posts:
    493
    Hi- can you give us more info?

    1) Version of ProBuilder
    2) Version of Unity
    3) Same issue in a brand-new project, with only ProBuilder installed?

    Also, have you tried simply disabling the Auto Lightmapping? Sounds to me like Unity is trying to lightmap that scene while you are working on it. ProBuilder objects are "Static" by default, unlike standard Unity cubes, so they receive lightmaps.
     
  3. MackNugget

    MackNugget

    Joined:
    Dec 4, 2012
    Posts:
    34
    I'm experiencing the same.

    Auto lightmaping is disabled.

    1) Using 4.0.3
    2) Using 2018.3.4f1
    3) Using it in a brand new project.
     
  4. gabrielw_unity

    gabrielw_unity

    Unity Technologies

    Joined:
    Feb 19, 2018
    Posts:
    493
    Hi MackNugget, thanks for the details! If this is happening in a clean project with only ProBuilder installed, and auto-lightmapping enabled...I can't imagine how PB would cause this. Does it lag when:

    1) ProBuilder is installed, but no PB cubes or UI in thet scene?
    2) PB is installed, PB window open, but no pb shapes?
    3) PB installed, no PB window, some pb shapes?
    4) PB installed, pb window open, pb shapes in scene?

    Thanks! -gw
     
  5. MackNugget

    MackNugget

    Joined:
    Dec 4, 2012
    Posts:
    34
    I uninstalled and reinstalled the asset and sit seemed to help.