Search Unity

  1. Unity 2018.3 is now released.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. Want more efficiency in your development work? Sign up to receive weekly tech and creative know-how from Unity experts.
    Dismiss Notice
  4. Build games and experiences that can load instantly and without install. Explore the Project Tiny Preview today!
    Dismiss Notice
  5. Nominations have been announced for this years Unity Awards. Celebrate the wonderful projects made by your peers this year and get voting! Vote here!
    Dismiss Notice
  6. Want to provide direct feedback to the Unity team? Join the Unity Advisory Panel.
    Dismiss Notice
  7. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice

ProBuilder 2.9.8f3. This GameObject has overlapping UVs

Discussion in 'World Building' started by AlexanderZotov, May 28, 2018.

  1. AlexanderZotov

    AlexanderZotov

    Joined:
    Mar 4, 2016
    Posts:
    6
    Hi guys! Can anyone tell me please what is the problem? Once I create new shape (even simple cube) I get such warning

    There are 1 objects in the Scene with overlapping UV's. Please see the details list below or use the 'UV Overlap' visualisation mode in the Scene View or Object Maps for more information.

    - Cube: 384 texels

    Edit. Same with ProBuilder 3.0.8 and Unity 2018.1.1f1
     
    Last edited: May 28, 2018
  2. se

    se

    Joined:
    May 20, 2013
    Posts:
    22
    I had a similar issue and @kaarrrllll pointed out to me that you may need to increase the lightmap resolution in the lighting window depending on what Unity version you're using. Alternatively you can also increase the lightmap padding in the ProBuilder UV editor (switch to UV2 in upper right select).
     
  3. AlexanderZotov

    AlexanderZotov

    Joined:
    Mar 4, 2016
    Posts:
    6
    Thanks for your reply. Unfortunately nothing works. I read about setting Lightmap Resolution to 40 before. It didn't help. And switching to UV2 doesn't work neither.
     
  4. alefbona

    alefbona

    Joined:
    Apr 30, 2018
    Posts:
    2
    Any update? I have the same problem...
     
  5. BritTiggs

    BritTiggs

    Joined:
    Apr 2, 2018
    Posts:
    1
    Same issue here. New project on Unity 2018.1.1f1, only package is ProBuilder (3.0.9). Create a cube -- instant overlapping UV's.

    Turning the Pack Margin up to 40 (in ProBuilder/ Generate UV2 options) seemed to fix most of the overlaps for me.
     
  6. kaneco2013

    kaneco2013

    Joined:
    Nov 18, 2018
    Posts:
    1
    Thank you! It`s works!