Search Unity

  1. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Problems with Unity 2020.1.6f1 & TMPro 3.0.1 (no font style, shader compile errors)

Discussion in 'UGUI & TextMesh Pro' started by Bren, Sep 24, 2020.

  1. Bren

    Bren

    Joined:
    Aug 28, 2008
    Posts:
    191
    Pretty new to TMPro and running into strange problems.

    I'd like to generate an outline font, but the Font Asset Creator doesn't have a Font Style option as shown in docs/vids.

    upload_2020-9-24_14-40-8.png

    I'm trying this with the standard Windows 10 Verdana.ttf font.

    As well, after (re)importing TMPro Essentials, I get a couple shader compilation errors.

    upload_2020-9-24_14-31-0.png

    I wonder if this is because of the directory structure?

    upload_2020-9-24_14-34-38.png

    Also strange, I can't check any of the unchecked boxes, nor does the "All" button work, and the Shaders folder is greyed out?

    I'm mainly interested in how to create an outline, but sharing all this strangeness in case it's related. Tried restarted Unity but that didn't help.

    Suggestions?
     

    Attached Files:

  2. Stephan_B

    Stephan_B

    Unity Technologies

    Joined:
    Feb 26, 2017
    Posts:
    4,984
    The option to create an Outline font was removed when 1.4.0 was introduced.

    An outline font style as seen in the image below can be achieved by adjusting the material properties where you set the face color to be transparent and then add an outline.

    upload_2020-9-24_15-47-24.png

    Let me know if that works for your needs?

    Yes. Although the shaders have been moved outside of the Resources folder, when importing the updated TMP Essential Resources, the new shaders will be imported into their new location while the existing shaders kept in the previous location.

    To resolve this, you could (1) move the new shaders with the existing shaders in the Resources folder and then move that Shaders folder back where the new shader it or (2) move the existing shaders with the new shaders or (3) delete the whole "TextMesh Pro" folder and then re-import the TMP Essential Resources and TMP Examples & Extras. That is provided you didn't save resources / assets inside the current "TextMesh Pro" folder.

    After moving the shaders, if you still get an error, you can select re-import on that folder or on the TMPro_Properties.cginc.
     
unityunity