Search Unity

Audio Problems With Max Sound Distance?

Discussion in 'Audio & Video' started by BadAppleGamer, Jan 14, 2020.

  1. BadAppleGamer

    BadAppleGamer

    Joined:
    Jan 13, 2020
    Posts:
    6
    Hey there!

    Basically I have set up a fire animation and a audio source to play a .ogg sound file of a fire burning. No matter what settings I choose (Obviously doing something wrong) I can't get it to stop play the sound at a certain distance. Basically I would like the fire crackling sound to stop playing when the player is not near the fire. Can anyone please help? I would appreciate it a lot! =) Thanks in advance. Best wishes and regards, Glyn.
     
  2. JLF

    JLF

    Joined:
    Feb 25, 2013
    Posts:
    76
    Common things to miss are accidentally changing the volume curve so that it's not zero at max distance and the sound not being fully 3D. If it's not these, could you post a shot of Audio Source settings?
     
  3. BadAppleGamer

    BadAppleGamer

    Joined:
    Jan 13, 2020
    Posts:
    6
    Thanks for the speedy reply JFL! =)

    I've uploaded a screenshot of my predicament. Not too sure still what I'm doing wrong but thanks for helping! I'm still kinda new to Unity after using UE4 for years but I think I'm beginning to prefer Unity! =D Thanks btw.
     

    Attached Files:

    JLF likes this.
  4. JLF

    JLF

    Joined:
    Feb 25, 2013
    Posts:
    76
    Your spatial blend is set to 2D, means it's unaffected by the 3D engine. Set it to 1 and it should work.
     
  5. BadAppleGamer

    BadAppleGamer

    Joined:
    Jan 13, 2020
    Posts:
    6
    Aw man!!! Thank you ever so much, that worked! Something so simple causing me a whole heap of trouble but it's fixed now thanks to you my friend. Nice one dude! =)
     
    JLF likes this.
  6. JLF

    JLF

    Joined:
    Feb 25, 2013
    Posts:
    76
    Glad I could help.
     
unityunity