Search Unity

Problem with transparent textures in Shader Graph

Discussion in 'Shaders' started by ForMiSoft, Aug 21, 2018.

  1. ForMiSoft

    ForMiSoft

    Joined:
    Dec 5, 2016
    Posts:
    7
    Hi, I'm trying to create a shader with a transparent texture, but without success. The picture shows that the texture contains an alpha channel, but even the first preview of Sample Texture 2D shows the texture as opaque. I added the slider for AplhaClipTreshold only as proof of the aplha channel, . Also, in the Select Texture dialog, you can see that the texture is transparent. Could anyone please advise me what I'm doing wrong?

    Unity version: 2018.2.4f1
    Lightweight Render Pipeline version: 3.0.0-preview
    Shader Graph version: 3.0.0-preview

    Image1.png
     
    Last edited: Aug 21, 2018
  2. ryozombaku

    ryozombaku

    Joined:
    Jun 24, 2017
    Posts:
    3
    When your mouse is on the PBR Master node you can see a little Settings button. Go here and change Surface to Transparent.
     
  3. ForMiSoft

    ForMiSoft

    Joined:
    Dec 5, 2016
    Posts:
    7
    Thank you.
     
  4. Velo222

    Velo222

    Joined:
    Apr 29, 2012
    Posts:
    1,291
    Wow, I wonder why they felt the need to hide it like that. Thank you.