Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. Have a look at our Games Focus blog post series which will show what Unity is doing for all game developers – now, next year, and in the future.
    Dismiss Notice

Question Problem When targeting API higher than 30

Discussion in 'General Discussion' started by RiddleTower, Nov 22, 2022 at 2:39 PM.

  1. RiddleTower

    RiddleTower

    Joined:
    Sep 30, 2021
    Posts:
    17
    Hello everyone. I recently published my app on the google play store.
    Some friends told me that when they download the app and hit to open it it just close instantly and i found out this happens when the android api is 31 and higher.
    If i send an APK with target API 30 everything runs perfectly but play store doesn't allow anymore to upload apps targeting API lower than 31.

    Any ideas what is causing this issue ?
     
  2. Kaymax

    Kaymax

    Joined:
    Feb 12, 2017
    Posts:
    27
    maybe they need to update their phones to latest OS version? please try that and ping me, Im also interested in this
     
  3. RiddleTower

    RiddleTower

    Joined:
    Sep 30, 2021
    Posts:
    17
    Not its not that kind of error. I saw that many people have this error aswell.
    Everyone reporting this to me have pretty new smartphones so its exactly the error stated above when the api level is higher than 31 the app crashes.

    Having the build target api 30 was a solution but now you can't upload an app at the play store if its not 31 or higher.
    Tried many things as editing the manifest file etc.etc. but still nothing :/
     
  4. RiddleTower

    RiddleTower

    Joined:
    Sep 30, 2021
    Posts:
    17
  5. neginfinity

    neginfinity

    Joined:
    Jan 27, 2013
    Posts:
    12,147
    You need to read adb logcat logs and see if your game throws an exception. Because an unhandled exception will result in program termination. If you're trying to do something that requires some sort of fancy permission on API level 31 and you haven't requested it properly, then chances are you'll get an exception.
     
  6. RiddleTower

    RiddleTower

    Joined:
    Sep 30, 2021
    Posts:
    17
unityunity