Search Unity

  1. Improved Prefab workflow (includes Nested Prefabs!), 2D isometric Tilemap and more! Get the 2018.3 Beta now.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. Let us know a bit about your interests, and if you'd like to become more directly involved. Take our survey!
    Dismiss Notice
  4. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice
  5. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice

Problem UDP after second lauch

Discussion in 'Connected Games' started by loicHusson, May 16, 2018.

  1. loicHusson

    loicHusson

    Joined:
    Apr 4, 2018
    Posts:
    3
    Hello,
    I have an application which read data received on the UDP port. That work perfectly on the Unity test but when I build and run, that work the first time but if I try to relauch it, it doesn't received any data. I have to rebuild-it to read another data. It's annoying.
    If someone know what can do that, that seems to come from the Unity file, but I don't know which.

    Thank you for reading
    (and sorry for potential bad english)
     
  2. loicHusson

    loicHusson

    Joined:
    Apr 4, 2018
    Posts:
    3
    I have try other thing, if I just build it and lauch it with the .exe, I don't received any data on the UDP, even the 1st time
     
  3. loicHusson

    loicHusson

    Joined:
    Apr 4, 2018
    Posts:
    3
    After debugging, the problem is a fileName (Assets/... doesn't exist when you build). If someone know how to let folder after a build?