Search Unity

  1. Are you interested in providing feedback directly to Unity teams? Sign up to become a member of Unity Pulse, our new product feedback and research community.
    Dismiss Notice

Problem running build remotely with x11. Screen resolution selector shows, then there are problems.

Discussion in 'Linux' started by pyjamaslug, May 15, 2020.

  1. pyjamaslug

    pyjamaslug

    Joined:
    Jul 5, 2017
    Posts:
    46
    Hi,
    I'm trying to run my build remotely with X11 forwarding turned on. I have checked to see if x11 works (by running a built in app) and it does. When I run my unity app (which is nothing more than a rotating cube), the screen resolution dialog shows and I can click the start button and the app then crashes with a SIGABRT.

    The Player.log tells me:

    Error getting system window info: Invalid window
    Unsupported windowing backend 0

    but unfortunately I don't know what it means to have an unsupported windowing backend.

    I'm using vulkan (and the drivers work fine when running locally)

    I'm running MobaXterm on a win10 machine at my end and logging in over ssh

    I'd really appreciate some insights into this.
     
  2. pyjamaslug

    pyjamaslug

    Joined:
    Jul 5, 2017
    Posts:
    46
    Here's some more information on this problem. I have switched to OGL just in case vulkan causes problems but still get the same problems.

    I checked in the sshd_config to see if XForwarding is set, answer: yes.
    when I launch now, I get a 'No protocol specified' message and the app shows up in the process list with the cpu at 100% so it is obviously doing something evil.
    The log shows:
    Desktop is 0 x 0 @ 0 Hz
    No protocol specified

    So I checked the DISPLAY environment variable. it is set to 11 so I launched with:
    DISPLAY=:11.0 ./<exe_name>

    and it no longer gives me a 'no protocol specified' message but it doesn't seem to run either.
    The log gives me this:


    Display 0 'default 42"': 3840x1080 (primary device).
    Desktop is 3840 x 1080 @ 0 Hz
    Unable to find a supported OpenGL core profile
    Failed to create valid graphics context: please ensure you meet the minimum requirements
    E.g. OpenGL core profile 3.2 or later for OpenGL Core renderer
    No supported renderers found, exiting
    (Filename: Line: 618)

    primary device shown there is my dual monitor desktop on my local machine so it is definitely trying to launch over here but why can't it find OpenGL?
     
unityunity