Search Unity

Problem: Noise artifacts

Discussion in 'General Graphics' started by WILEz1975, Feb 19, 2019.

  1. WILEz1975

    WILEz1975

    Joined:
    Mar 23, 2013
    Posts:
    288
    Hello,
    I have problems with graphic artifacts on my game (Star Shift).
    Some "dots" (squares actually) that make a strange noise effect.
    As per video, they do not always appear but only in some places (minute 0:56).

    (


    What could it be?
     
  2. WILEz1975

    WILEz1975

    Joined:
    Mar 23, 2013
    Posts:
    288
  3. bgolus

    bgolus

    Joined:
    Dec 7, 2012
    Posts:
    6,748
    If you're using the Post Processing Stack on the asset store, make sure you have "suppress NaN propagation" checked (I can't remember exactly what it's called or where the setting is in V1). If that is enabled, then you probably need to upgrade to the latest V2 version on github which has that enabled by default, though it was broken in builds from early last year.
     
  4. WILEz1975

    WILEz1975

    Joined:
    Mar 23, 2013
    Posts:
    288
    I use V2.
    Thanks for the reply. I already use V2 version.



    Is it possible to manage the HDR?
    Or is it possible to "simulate" the HDR with some post effects? So as to disable it in the camera script.
     
    Last edited: Feb 20, 2019
  5. bgolus

    bgolus

    Joined:
    Dec 7, 2012
    Posts:
    6,748
    How old is the version you have?

    When you disable HDR on the camera, the black dots go away because LDR formats can't store NaN or infinite values, only 0.0 through 1.0. However, they can only store values between 0.0 and 1.0, where as HDR formats can store values between -infinity and +infinity (really more usefully between -65535.0 and +65535.0 as Unity defaults to a 16 bit float format). Disabling HDR means you don't store values above 1.0, so you usually have to really over scale bloom and bring down the threshold for when it starts blooming. This tends to give games that kind of hazy, vaseline-over-the-lense look that a lot of games from 10 years ago had when bloom first started to be a thing.

    "Stop NaN Propagation" should absolutely fix this as it'll clamp any value that was stored as a NaN to be black instead. The fact that it doesn't means it's probably broken in the version you're using. I just checked and it's working properly for the version in package manager (which I believe should be roughly the same as version you get from github if you get latest). Try updating the version you're using.