Search Unity

  1. Click here to see what's on sale for the "Best of Super Sale" on the Asset Store
    Dismiss Notice
  2. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Pressing "play" often does nothing - it will never play/stop again until restarting Unity

Discussion in '5.6 Beta' started by MrLucid72, Mar 22, 2017.

  1. MrLucid72

    MrLucid72

    Joined:
    Jan 12, 2016
    Posts:
    808
    1. What happened

    I click play in the editor, the play button sticks, and nothing happens. if I click play again, it clicks but stays play. It never stops. If I click pause, that sticks too, but nothing extra happens.

    2. How we can reproduce it using the example you attached

    * Just randomly press play. I've seen others experience too. My teammate reports this happening ALL the time -- me too.

    * It does't FREEZE Unity, though -- I can still do anything within Unity EXCEPT play. I can even close properly, "Are you sure you want to save this scene before exiting?" I save then exit cleanly.

    * Here's a screencast: http://recordit.co/Toai8OviNP

    * Case # 893748
     
    Last edited: Mar 22, 2017
  2. jsadler

    jsadler

    Joined:
    May 31, 2013
    Posts:
    10
    I can confirm this in 5.5.2p3. It seems to only happen if the 'Services' tab is active and one of the services are turned on. Never got around to figuring out which service it is. I just turned them all off and closed the Services tab until I need them again.

    After that, the play button works normally for me.

    I noticed you had collab active which is why I'm chiming in.
     
unityunity