Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

Prefab inspector won't stay open - Unity 2018 latest build

Discussion in 'Prefabs' started by Elvenmonk, Aug 12, 2019.

  1. Elvenmonk


    May 4, 2019

    I am making a tower defense game and I am trying to drag my check points into my prefab. However, I can't grab the individual check points and put them into my prefab. The second I try to go back to being able to selecting my checkpoints the inspection menu goes away.

    Any ideas on how to do this?

    The first picture is my scene. The second picture is me opening my enemy prefab and then locking it. The third is me trying to go back to access the checkpoint way points but the prefab screen is gone despite me locking it.

    I have added a enemy prefab to the scene and tried editing it that way but when I try to override it wont save any of it. It'll just update the waypoint amount but not the waypoints themselves.
    Edit again:
    Even making it its own original prefab doesn't save the waypoints.

    Attached Files:

    Last edited: Aug 12, 2019
  2. ElvisFan


    Oct 4, 2017
    I'm having the same problem. I've even tried nesting the checkpoints as a child of enemy, but there was no movement from the enemy. I updated to Unity 2019.2 hoping that issue would be resolved, but sadly it wasn't. Post if you've discovered a method and I'll do the same.
  3. APSchmidt


    Aug 8, 2016
    To add something to a prefab, you must put in in the hierarchy view, add whatever you want to it and then update the prefab. :)