Search Unity

Precomputed GI dissapears when I enter play mode.

Discussion in 'Global Illumination' started by wadewt, Nov 23, 2016.

  1. wadewt

    wadewt

    Joined:
    Mar 17, 2013
    Posts:
    14
    Hello GI Forum,

    So I'm making a scene at the moment, it's a cave, there's some holes in the roof for sun to come in. I am using precomputed realtime GI. Whenever I finish a bake I can look at it in the editor in scene view and it looks nice. Whenever I go to test it and hit play, my GI is immediately gone. Upon returning to the editor it has dissapeared and if I have "auto" ticked for the building it will just start calculating it over again.

    Does anyhow know what's up or how I could fix it? It had been working fine for some time but now it's just stopped working. Even the light probe information is lost.

    Not sure if the following makes a difference but I figured I'd include it: This is for VR and I'm using a vive when I hit play, The cave is also made of many fairly high resolution meshes. I'm not sure this is a problem, though, as I haven't had any performance issues and the precompute finishes without a problem, it just dissapears when I hit play. My realtime resolution is set to 2.

    If there's any information I've missed lemme know.

    Thanks,
     
  2. AcidArrow

    AcidArrow

    Joined:
    May 20, 2010
    Posts:
    5,825
    Untick auto and press build.
     
  3. AcidArrow

    AcidArrow

    Joined:
    May 20, 2010
    Posts:
    5,825
    Also since this question has popped up quite a few times, I think maybe auto is doing more harm than good. Maybe the functionality needs a bit of redesign for how it's presented.
     
  4. wadewt

    wadewt

    Joined:
    Mar 17, 2013
    Posts:
    14
    Unity is behaving again, but I'm not sure this was a problem with auto. Typically when I have auto enabled I can enter and exit play mode without any problems. This time when I entered play mode my bake would just disappear as though it never existed. I did a few things while trying to make it behave. I baked once more, and then set my gi cache to be read only and when I entered play mode it remained. I was messing around with a few things at the time also so I'm not sure if that's what made it behave or not, afterwards I turned off read only and now the automatic baking is working again: I can go into and out of play mode without losing the precompute.