Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

Question Precariously Hung in the Balance

Discussion in 'Physics for ECS' started by roryo, Dec 12, 2020.

  1. roryo

    roryo

    Joined:
    May 21, 2009
    Posts:
    1,479
    With a cycloidal pulse sliding the ground to the right, a slender Havock Physics block sways then unrealistically stops, seemingly reaching a perfect balance on its corner, while a PhysX block with the same dimensions continues into a rocking motion.

    TeeterStop.gif

    In the real world, such a precarious balancing act would not be believable. With other, even slightly different values for the acceleration of the pulse, the Havoc block sways, rocks and falls comparably to the PhysX version.

    I can't figure out how this undesirable balancing act is achieved. I have turned "Enable Sleeping" off in the Havoc Physics Configuration and also tried setting Linear and Angular Damping to 0. I am using Contact Point Welding (if that is removed, the block does not stop on edge like this, but its motion is much more erratic, as discussed here).

    Is there something I can do to make sure that such an "unstable equilibrium" does not happen?
     
    Last edited: Dec 12, 2020
  2. milos85miki

    milos85miki

    Joined:
    Nov 29, 2019
    Posts:
    197
    Hi @roryo , did you maybe try to see what's happening in Havok Visual Debugger?
    It's under Window->Analysis, but you should enable it in HavokPhysiscConfiguration first.

    Since you're seeing a diff when welding is ON and OFF, I guess you did add ConvertToEntity component to the object where HavokPhysiscConfiguration component was added (otherwise HavokPhysiscConfiguration would have no effect).

    It would be useful if you could share a minimal project that reproduces the problem...