Search Unity

Help Wanted (Potential Bug) Cache Server Mode for Asset Pipeline v2 always fails connection to local machine

Discussion in '2019.3 Beta' started by BTStone, Dec 3, 2019.

  1. BTStone

    BTStone

    Joined:
    Mar 10, 2012
    Posts:
    1,084
    Hey Unity,

    I can't quite pinpoint what's going on here, if I'm doing something wrong or this is just buggy.
    So in the preferences I wanted to activate the Cache Server in an empty project, since v1 of the AssetPipeline is deprecated I thought I'll use the v2 one.
    Set the Server Default Mode to "Enabled"
    Now the question is: what to type in to the default IP address when working locally and not an actual remote server.
    I tried these: localhost, Localhost, 127.0.0.0, my actual IP, nothing worked.
    I always got the "Connection failed" Warning:

    Screen.png

    On top of that, every time I type something into that IP Inputfield the editor stalls like 6 seconds until it processes the next character until my complete input was registered - what's wrong here?

    With the deprecated Asset Pipeline the setup was quite easier since you could set the Mode directly to Local and hadn't specify an IP, would be neat if it works like that again.
     
  2. BTStone

    BTStone

    Joined:
    Mar 10, 2012
    Posts:
    1,084
    Tried it with new release candidate 2019.3.0f3, exact same problems :/
     
  3. LeonhardP

    LeonhardP

    Unity Technologies

    Joined:
    Jul 4, 2016
    Posts:
    1,733
    Last edited: Dec 13, 2019 at 10:45 AM
  4. BTStone

    BTStone

    Joined:
    Mar 10, 2012
    Posts:
    1,084
    Oh, didn't know that. Maybe you should put an Warning to those Preferences, pointing out that one should install that accelerator package in order to get it to work.
     
    LeonhardP likes this.