Search Unity

Post processing (V2) renders blank screen on HTC Vive and in editor

Discussion in 'VR' started by Drebble, May 21, 2019.

  1. Drebble

    Drebble

    Joined:
    Apr 10, 2019
    Posts:
    7
    Hi all

    Using Unity 2019.1.2f1 with Steam VR plugin V2.2.0

    I've set up the post process volume and post process layer on the Unity default camera and also the Vive player prefab camera (VRCamera).

    When I make the unity camera the main camera the post processing seems to work fine in the scene view but when I click play the game scene view is black.

    When I switch the main camera from unity to the Steam VRCamera I get a 2D debug button on the scene view which I can toggle to VR, but nothing renders to the HMD.

    If I'm setting it up incorrectly then I'd expect it not to work in the scene view, is Post Processing V2 broken in 2019.1 and / or VR (Vive) or am I doing something wrong?

    Cheers
    Jim
     
  2. Drebble

    Drebble

    Joined:
    Apr 10, 2019
    Posts:
    7
    OK, so thanks to Amadhia-Albee I've got the output working on the HMD and Game view (You have to uncheck the "directly to camera" option in the post process layer on the camera)

    However like Amadhia-Albee I am also having issues with ghost objects and artifacts in the center of the view although AA seems to work which is in the layer component not the volume. Maybe the issue is in the volume component but there is definitely seems to be something weird going on with PP V2 in VR in Unity 2019.1

    Anyone got round this issue?

    AA Only.jpg AO.jpg Bloom.jpg

    Cheers
    Jim