Search Unity

Post Processing not working in Unity 2019.1.0f2

Discussion in 'General Graphics' started by rafaelferrari1, Apr 16, 2019.

  1. rafaelferrari1

    rafaelferrari1

    Joined:
    Jan 6, 2014
    Posts:
    8
    Hi you all!

    I'm trying to use Post Processing package in my project, that is updated to use Unity 2019.1.0f2.

    When I add Post Process Layer to my camera, it remove complete any render of scene objects, and give me a pink triangule in front of the camera, as you can see in the image bellow:

    upload_2019-4-16_15-49-38.png

    On the first time I add the script, it gave me this error on one of the Hidden shaders:

    upload_2019-4-16_15-56-45.png

    I'm also using LWRP on my project. I had tried to remove it and change for the regular render, and the problem persist.

    When I turn the Post Process Layer script off, everything is render again.

    I'm using Post Processing from Package Manager, and it's updated with the last version available.

    Anyone have some idea why this problem is happening? Should I try to download the Post Process from github, instead Package Manager, just for this unity version?

    Thanks!
     
  2. alexisamachine

    alexisamachine

    Joined:
    Apr 23, 2019
    Posts:
    1
    Hey

    I had this exact same issu, I'm using Unity 2019.1, Open VR 1.0.5, Lightweight RP 5.7.2 and Post Processing 2.1.6. with an HTC Vive headset.

    The way I solved this issue was to delete the Post Processing files from the package manager, and then made sure it was completely gone by checking the folder using the windows explorer. Then delete all PP Profiles, layers etc. you might have in your scene.

    Then, just re-import the PP package from the package manager and follow all the standard steps to set it up on your main camera, and it should work properly now.